summaryrefslogtreecommitdiffstats
path: root/abs/extra/pyxis
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/pyxis')
-rw-r--r--abs/extra/pyxis/PKGBUILD27
-rw-r--r--abs/extra/pyxis/__changelog2
-rw-r--r--abs/extra/pyxis/python2.patch90
3 files changed, 0 insertions, 119 deletions
diff --git a/abs/extra/pyxis/PKGBUILD b/abs/extra/pyxis/PKGBUILD
deleted file mode 100644
index 436db6e..0000000
--- a/abs/extra/pyxis/PKGBUILD
+++ /dev/null
@@ -1,27 +0,0 @@
-# Contributor: Corey Ling <kasuko@gmail.com>
-
-pkgname=pyxis
-pkgver=0.2.3
-pkgrel=2
-pkgdesc="SIRIUS/XM Internet Radio Player for Command Line"
-url="http://www.ionshard.com/pyxis"
-arch=(i686 x86_64)
-license=('GPL')
-depends=('python2-beautifulsoup4' 'mplayer' 'python2')
-makedepends=('python2' 'setuptools')
-optdepends=('python-notify: for OSD notifications')
-conflicts=()
-replaces=()
-backup=()
-options=(!emptydirs)
-install=
-source=( "https://github.com/Kasuko/pyxis/tarball/v$pkgver" "python2.patch" )
-
-build() {
- cd $srcdir/Kasuko-pyxis*
- patch -p0 < ../../python2.patch
- python2 setup.py install --root=$pkgdir
-}
-
-md5sums=('b2f42dc7bb5e2a0a6c0ef0ff6f327790'
- '3096a832aac9e155cd21e2d108168516')
diff --git a/abs/extra/pyxis/__changelog b/abs/extra/pyxis/__changelog
deleted file mode 100644
index 2410a63..0000000
--- a/abs/extra/pyxis/__changelog
+++ /dev/null
@@ -1,2 +0,0 @@
-9/3/12 chw
-Changed dep from python-beautiful to python2-beautifulsoup4.
diff --git a/abs/extra/pyxis/python2.patch b/abs/extra/pyxis/python2.patch
deleted file mode 100644
index e53cf99..0000000
--- a/abs/extra/pyxis/python2.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-diff --git bin/pyxis bin/pyxis
-index 9b447fb..0350278 100755
---- bin/pyxis
-+++ bin/pyxis
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python2
- #Pyxis and Original Sipie: Sirius Command Line Player
- #Copyright (C) Corey Ling, Eli Criffield
- #
-diff --git pyxis/Config.py pyxis/Config.py
-index d4d6d29..a36778e 100644
---- pyxis/Config.py
-+++ pyxis/Config.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2
- #Pyxis and Original Sipie: Sirius Command Line Player
- #Copyright (C) Corey Ling, Eli Criffield
- #
-diff --git pyxis/Debug.py pyxis/Debug.py
-index d4af851..bf1bd6e 100644
---- pyxis/Debug.py
-+++ pyxis/Debug.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2
- #Pyxis
- #Copyright (C) Corey Ling
- #
-diff --git pyxis/Exceptions.py pyxis/Exceptions.py
-index a1b5f8d..0270a02 100644
---- pyxis/Exceptions.py
-+++ pyxis/Exceptions.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2
- #Pyxis and Original Sipie: Sirius Command Line Player
- #Copyright (C) Corey Ling, Eli Criffield
- #
-diff --git pyxis/Interface.py pyxis/Interface.py
-index 3c60a7c..1b0c05c 100644
---- pyxis/Interface.py
-+++ pyxis/Interface.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2
- #Pyxis and Original Sipie: Sirius Command Line Player
- #Copyright (C) Corey Ling, Eli Criffield
- #
-diff --git pyxis/Player.py pyxis/Player.py
-index 8e945ba..c467acd 100644
---- pyxis/Player.py
-+++ pyxis/Player.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2
- #Pyxis and Original Sipie: Sirius Command Line Player
- #Copyright (C) Corey Ling, Eli Criffield
- #
-diff --git pyxis/ProviderCanada.py pyxis/ProviderCanada.py
-index 4d84952..9ff2aa6 100644
---- pyxis/ProviderCanada.py
-+++ pyxis/ProviderCanada.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2
- #Pyxis and Original Sipie: Sirius Command Line Player
- #Copyright (C) Corey Ling, Eli Criffield
- #
-diff --git pyxis/ProviderUSA.py pyxis/ProviderUSA.py
-index 7c30eaf..b1fb950 100644
---- pyxis/ProviderUSA.py
-+++ pyxis/ProviderUSA.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2
- #Pyxis and Original Sipie: Sirius Command Line Player
- #Copyright (C) Corey Ling, Eli Criffield
- #
-diff --git pyxis/Sirius.py pyxis/Sirius.py
-index 30a25d6..75f1fb6 100644
---- pyxis/Sirius.py
-+++ pyxis/Sirius.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2
- #Pyxis and Original Sipie: Sirius Command Line Player
- #Copyright (C) Corey Ling, Eli Criffield
- #