summaryrefslogtreecommitdiffstats
path: root/abs/extra/qscintilla
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/qscintilla')
-rw-r--r--abs/extra/qscintilla/PKGBUILD59
-rw-r--r--abs/extra/qscintilla/configure.py-objdir-support.diff39
2 files changed, 0 insertions, 98 deletions
diff --git a/abs/extra/qscintilla/PKGBUILD b/abs/extra/qscintilla/PKGBUILD
deleted file mode 100644
index b0f83be..0000000
--- a/abs/extra/qscintilla/PKGBUILD
+++ /dev/null
@@ -1,59 +0,0 @@
-# $Id$
-# Maintainer: Andrea Scarpino <andrea@archlinux.org>
-# Contributor: Douglas Soares de Andrade <dsa@aur.archlinux.org>
-
-pkgbase=qscintilla
-pkgname=('qscintilla' 'python2-qscintilla')
-pkgver=2.5.1
-pkgrel=3
-license=('GPL')
-arch=('i686' 'x86_64')
-url="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
-makedepends=('python2-pyqt')
-source=("http://riverbankcomputing.com/static/Downloads/QScintilla2/QScintilla-gpl-${pkgver}.tar.gz"
- 'configure.py-objdir-support.diff')
-md5sums=('dd7edef5ff674d307057a3c12dbd8fce'
- '8cf9c06252e2f11ab00e62848e322fd3')
-
-
-build() {
- cd "${srcdir}/QScintilla-gpl-${pkgver}"
- patch -Np1 -i "${srcdir}/configure.py-objdir-support.diff"
-
- cd Qt4
- qmake qscintilla.pro
- make
-
- cd ../designer-Qt4
- qmake designer.pro INCLUDEPATH+=../Qt4 QMAKE_LIBDIR+=../Qt4
- make
-
- cd ../
- cp -rf Python Python2
- cd Python
- python configure.py -n ../Qt4/ -o ../Qt4 -c -p 4
- make
-
- cd ../Python2
- python2 configure.py -n ../Qt4/ -o ../Qt4 -c -p 4
- make
-}
-
-package_qscintilla() {
- pkgdesc="A port to Qt4 of Neil Hodgson's Scintilla C++ editor class"
- depends=('qt')
-
- cd "${srcdir}/QScintilla-gpl-${pkgver}/Qt4"
- make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
-
- cd "${srcdir}/QScintilla-gpl-${pkgver}/designer-Qt4"
- make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
-}
-
-package_python2-qscintilla() {
- pkgdesc="Python 2 bindings for QScintilla2"
- depends=('pyqt' 'qscintilla')
-
- cd "${srcdir}/QScintilla-gpl-${pkgver}/Python2"
- make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
-}
diff --git a/abs/extra/qscintilla/configure.py-objdir-support.diff b/abs/extra/qscintilla/configure.py-objdir-support.diff
deleted file mode 100644
index b595de1..0000000
--- a/abs/extra/qscintilla/configure.py-objdir-support.diff
+++ /dev/null
@@ -1,39 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 02_configure.dpatch by Torsten Marek <shlomme@debian.org>
-##
-## DP: patch the configure script for the Python bindings to support object dir builds
-
-@DPATCH@
-Index: qscintilla2-2.4.2/Python/configure.py
-===================================================================
---- qscintilla2-2.4.2.orig/Python/configure.py 2010-01-20 20:56:09.000000000 +0100
-+++ qscintilla2-2.4.2/Python/configure.py 2010-01-27 22:54:35.603870417 +0100
-@@ -33,6 +33,7 @@
- import glob
- import optparse
-
-+src_dir = os.path.dirname(os.path.abspath(__file__))
-
- # Import SIP's configuration module so that we have access to the error
- # reporting. Then try and import the configuration modules for both PyQt3 and
-@@ -162,7 +163,7 @@
- if os.access(sciglobal, os.F_OK):
- # Get the QScintilla version string.
- _, sciversstr = sipconfig.read_version(sciglobal, "QScintilla", "QSCINTILLA_VERSION", "QSCINTILLA_VERSION_STR")
--
-+ return # Debian: do not check for the installed version, we're good this way.
- if glob.glob(os.path.join(opts.qscilibdir, "*qscintilla2*")):
- # Because we include the Python bindings with the C++ code we can
- # reasonably force the same version to be used and not bother about
-@@ -232,9 +233,9 @@
- argv.append(buildfile)
-
- if pyqt.pyqt_version >= 0x040000:
-- argv.append("sip/qscimod4.sip")
-+ argv.append(os.path.join(src_dir, "sip/qscimod4.sip"))
- else:
-- argv.append("sip/qscimod3.sip")
-+ argv.append(os.path.join(src_dir, "sip/qscimod3.sip"))
-
- os.system(" ".join(argv))
-