summaryrefslogtreecommitdiffstats
path: root/abs/extra/samba/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/samba/PKGBUILD')
-rw-r--r--abs/extra/samba/PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/abs/extra/samba/PKGBUILD b/abs/extra/samba/PKGBUILD
index f813ab6..13ddd78 100644
--- a/abs/extra/samba/PKGBUILD
+++ b/abs/extra/samba/PKGBUILD
@@ -10,11 +10,11 @@
pkgbase=samba
pkgname=('libwbclient' 'smbclient' 'samba')
-pkgver=4.1.14
+pkgver=4.3.4
# We use the 'A' to fake out pacman's version comparators. Samba chooses
-# to append 'a','b',etc to their subsequent releases, which pamcan
+# to append 'a','b',etc to their subsequent releases, which pacman
# misconstrues as alpha, beta, etc. Bad samba!
-_realver=4.1.14
+_realver=4.3.4
pkgrel=1
arch=(i686 x86_64)
url="http://www.samba.org"
@@ -23,6 +23,7 @@ makedepends=('python2' 'docbook-xsl' 'pkg-config' 'libbsd' 'db' 'popt' 'libcups'
'readline' 'tevent' 'acl' 'libldap' 'libcap' 'ldb>=1.1.15' 'krb5' 'pam'
'gnutls>=2.4.1' 'talloc' 'tdb' 'dbus')
source=(http://us1.samba.org/samba/ftp/stable/${pkgbase}-${_realver}.tar.gz
+ http://us1.samba.org/samba/ftp/stable/${pkgbase}-${_realver}.tar.asc
samba.logrotate
samba.pam
samba.service
@@ -33,6 +34,7 @@ source=(http://us1.samba.org/samba/ftp/stable/${pkgbase}-${_realver}.tar.gz
smbd@.service
winbindd.service
samba.conf)
+validpgpkeys=('52FBC0B86D954B0843324CDC6F33915B6568B7EA') #Samba Distribution Verification Key <samba-bugs@samba.org>
### UNINSTALL dmapi package before building!!!
build() {
@@ -105,7 +107,7 @@ depends=('glibc' 'libbsd')
install -d -m755 ${pkgdir}/usr/lib/samba
mv ${_pkgsrc}/usr/lib/samba/libwinbind-client*.so* ${pkgdir}/usr/lib/samba/
- mv ${_pkgsrc}/usr/lib/samba/libreplace.so* ${pkgdir}/usr/lib/samba/
+ #mv ${_pkgsrc}/usr/lib/samba/libreplace.so* ${pkgdir}/usr/lib/samba/
install -d -m755 ${pkgdir}/usr/lib/pkgconfig
mv ${_pkgsrc}/usr/lib/pkgconfig/wbclient.pc ${pkgdir}/usr/lib/pkgconfig/
@@ -120,9 +122,9 @@ depends=('popt' 'cifs-utils' 'tdb' "libwbclient>=$pkgver" 'ldb'
'tevent' 'libgcrypt' 'python2' 'talloc' 'readline' 'gnutls'
'libbsd' 'libldap' 'libcups')
- _smbclient_bins=('smbclient' 'smbclient4' 'rpcclient' 'smbspool'
+ _smbclient_bins=('smbclient' 'rpcclient' 'smbspool'
'smbtree' 'smbcacls' 'smbcquotas' 'smbget' 'net'
- 'nmblookup' 'nmblookup4' 'smbtar')
+ 'nmblookup' 'smbtar')
# Use samba-pkg as a staging directory for the split packages
# (This is so RPATHS and symlinks are generated correctly via
# make install, but the otherwise unsplit pieces can be split)
@@ -241,7 +243,8 @@ sys.path.insert(0, '/usr/lib/python${_pyver}/site-packages')" \
# copy ldap example
install -D -m644 ${srcdir}/samba-${_realver}/examples/LDAP/samba.schema ${pkgdir}/usr/share/doc/samba/examples/LDAP/samba.schema
}
-md5sums=('9f7bae123ed39d2aa9ba842d3a138d54'
+md5sums=('48df803c6c6c475a714cae82a2dc219e'
+ 'SKIP'
'5697da77590ec092cc8a883bae06093c'
'96f82c38f3f540b53f3e5144900acf17'
'ee4763a656cf00d92bfda31b6bb2c5cb'