summaryrefslogtreecommitdiffstats
path: root/abs/extra/sapphire/sapphire.patch
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/sapphire/sapphire.patch')
-rw-r--r--abs/extra/sapphire/sapphire.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/abs/extra/sapphire/sapphire.patch b/abs/extra/sapphire/sapphire.patch
new file mode 100644
index 0000000..ddd0653
--- /dev/null
+++ b/abs/extra/sapphire/sapphire.patch
@@ -0,0 +1,24 @@
+diff -ruaN sapphire-3.2.orig//Makefile sapphire-3.2/Makefile
+--- sapphire-3.2.orig//Makefile 2012-04-12 18:00:50.000000000 +0000
++++ sapphire-3.2/Makefile 2012-04-22 08:42:19.000000000 +0000
+@@ -4,7 +4,7 @@
+ #
+ MODNAME=sapphire
+ CONFLICTS=hid_topseed
+-BLACKLIST=/etc/modprobe.d/blacklist-$(CONFLICTS).conf
++BLACKLIST=$(DESTDIR)/etc/modprobe.d/blacklist-$(CONFLICTS).conf
+
+ ## MODPARMS is not used any more, but we have to nuke old copies to prevent issues:
+ MODPARMS=/etc/modprobe.d/$(MODNAME).conf
+@@ -49,8 +49,8 @@
+ depmod
+
+ install: $(MODNAME).ko clean_modparms modloader $(BLACKLIST)
+- cp sapphire_keymap.sh /usr/local/bin/
+- chmod a+rx /usr/local/bin/sapphire_keymap.sh
+- sync
++# cp sapphire_keymap.sh /usr/local/bin/
++# chmod a+rx /usr/local/bin/sapphire_keymap.sh
++# sync
+
+ all: install