summaryrefslogtreecommitdiffstats
path: root/abs/extra/sip/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/sip/PKGBUILD')
-rw-r--r--abs/extra/sip/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/abs/extra/sip/PKGBUILD b/abs/extra/sip/PKGBUILD
new file mode 100644
index 0000000..e3486f4
--- /dev/null
+++ b/abs/extra/sip/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: PKGBUILD 47992 2009-07-30 10:16:59Z pierre $
+# Maintainer: Douglas Soares de Andrade <douglas@archlinux.org>
+# Contributor: riai <riai@bigfoot.com>, Ben <ben@benmazer.net>
+
+pkgname=sip
+pkgver=4.9
+pkgrel=1
+pkgdesc="A tool that makes it easy to create Python bindings for C and C++ libraries."
+arch=(i686 x86_64)
+url="http://www.riverbankcomputing.com/software/sip/"
+license=('custom:"sip"')
+depends=('python>=2.6' 'gcc-libs')
+source=(http://riverbankcomputing.com/static/Downloads/sip4/${pkgname}-${pkgver}.tar.gz)
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ python configure.py -b /usr/bin \
+ -d /usr/lib/python2.6/site-packages \
+ -e /usr/include/python2.6 \
+ -v /usr/share/sip
+
+ make || return 1
+ make DESTDIR=${pkgdir} install
+ # fix permissions
+ chmod 644 ${pkgdir}/usr/lib/python2.6/site-packages/sipdistutils.py
+
+ install -m 644 -D LICENSE ${pkgdir}/usr/share/licenses/sip/LICENSE
+}