summaryrefslogtreecommitdiffstats
path: root/abs/extra/sip/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/sip/PKGBUILD')
-rw-r--r--abs/extra/sip/PKGBUILD65
1 files changed, 0 insertions, 65 deletions
diff --git a/abs/extra/sip/PKGBUILD b/abs/extra/sip/PKGBUILD
deleted file mode 100644
index 866d89d..0000000
--- a/abs/extra/sip/PKGBUILD
+++ /dev/null
@@ -1,65 +0,0 @@
-# $Id: PKGBUILD 162739 2012-06-29 11:34:13Z andrea $
-# Maintainer: Andrea Scarpino <andrea@archlinux.org>
-# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
-# Contributor: riai <riai@bigfoot.com>, Ben <ben@benmazer.net>
-
-pkgbase=sip
-pkgname=('sip' 'python2-sip')
-pkgver=4.13.3
-pkgrel=2
-arch=('i686' 'x86_64')
-url="http://www.riverbankcomputing.com/software/sip/"
-license=('custom:"sip"')
-makedepends=( 'python2')
-source=("http://www.riverbankcomputing.com/static/Downloads/sip4/${pkgbase}-${pkgver}.tar.gz")
-md5sums=('76192829cc42ec558db46e4f9e1d8ba9')
-
-build() {
- cd "${srcdir}"
- cp -r ${pkgbase}-${pkgver} python2-${pkgbase}-${pkgver}
-
- #cd "${srcdir}/${pkgbase}-${pkgver}"
- #python configure.py CFLAGS="${CFLAGS}" LFLAGS="${LDFLAGS}"
- #make
-
- ### Python2 version ###
- cd "${srcdir}/python2-${pkgbase}-${pkgver}"
- python2 configure.py CFLAGS="${CFLAGS}" LFLAGS="${LDFLAGS}"
- make
-}
-
-package_sip() {
- pkgdesc="A tool that makes it easy to create Python bindings for C and C++ libraries"
- depends=('glibc')
-
- cd "${srcdir}/python2-${pkgbase}-${pkgver}"
- make DESTDIR="${pkgdir}" install -C sipgen
-
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}
-
-package_python-sip1() {
- pkgdesc="Python 3.x SIP bindings for C and C++ libraries"
- depends=('sip' 'python')
-
- cd "${srcdir}/${pkgbase}-${pkgver}"
- make DESTDIR="${pkgdir}" install -C siplib
-
- install -Dm644 sipconfig.py "${pkgdir}"/usr/lib/python3.2/site-packages/sipconfig.py
- install -Dm644 sipdistutils.py "${pkgdir}"/usr/lib/python3.2/site-packages/sipdistutils.py
-
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}
-
-package_python2-sip() {
- pkgdesc="Python 2.x SIP bindings for C and C++ libraries"
- depends=('sip' 'python2')
-
- cd "${srcdir}/python2-${pkgbase}-${pkgver}"
- make DESTDIR="${pkgdir}" install -C siplib
-
- install -Dm644 sipconfig.py "${pkgdir}"/usr/lib/python2.7/site-packages/sipconfig.py
- install -Dm644 sipdistutils.py "${pkgdir}"/usr/lib/python2.7/site-packages/sipdistutils.py
-
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}