summaryrefslogtreecommitdiffstats
path: root/abs/extra/smartmontools/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/smartmontools/PKGBUILD')
-rw-r--r--abs/extra/smartmontools/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/extra/smartmontools/PKGBUILD b/abs/extra/smartmontools/PKGBUILD
new file mode 100644
index 0000000..dbee715
--- /dev/null
+++ b/abs/extra/smartmontools/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 6701 2008-07-27 13:29:59Z giovanni $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Jeff Mickey <jeff@archlinux.org>
+# Contributor: Jani Talikka <jani.talikka@gmail.com>
+
+pkgname=smartmontools
+pkgver=5.38
+pkgrel=1
+pkgdesc="Control and monitor S.M.A.R.T. enabled ATA and SCSI Hard Drives."
+url="http://smartmontools.sourceforge.net"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('gcc-libs')
+backup=('etc/smartd.conf')
+source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz \
+ smartd)
+
+build()
+{
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make || return 1
+ make DESTDIR=${startdir}/pkg install
+ rm -rf ${startdir}/pkg/etc/rc.d
+ install -D -m 755 ../smartd ${startdir}/pkg/etc/rc.d/smartd
+}
+md5sums=('a282846532ecbd6b4a28072373b3a70b' '850f98b6792b7642ff193a49a2f1139d')