summaryrefslogtreecommitdiffstats
path: root/abs/extra/source-highlight/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/source-highlight/PKGBUILD')
-rw-r--r--abs/extra/source-highlight/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/extra/source-highlight/PKGBUILD b/abs/extra/source-highlight/PKGBUILD
new file mode 100644
index 0000000..6c1ae0c
--- /dev/null
+++ b/abs/extra/source-highlight/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id$
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+
+pkgname=source-highlight
+pkgver=3.1.8
+pkgrel=14
+pkgdesc="Convert source code to syntax highlighted document"
+arch=('x86_64')
+url="http://www.gnu.org/software/src-highlite/"
+license=('GPL')
+depends=('bash' 'boost-libs')
+makedepends=('ctags' 'boost')
+source=("ftp://ftp.gnu.org/gnu/src-highlite/${pkgname}-${pkgver}.tar.gz")
+md5sums=('3243470706ef5fefdc3e43b5306a4e41')
+
+build() {
+ cd ${pkgname}-${pkgver}
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-bash-completion=/usr/share/bash-completion/completions
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+
+ make prefix="${pkgdir}/usr" bash_completiondir="${pkgdir}/usr/share/bash-completion/completions" install
+
+ # PKGBUILD syntax highlighting
+ echo -e "\npkgbuild = sh.lang" >> "${pkgdir}"/usr/share/${pkgname}/lang.map
+}