summaryrefslogtreecommitdiffstats
path: root/abs/extra/sqlite/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/sqlite/PKGBUILD')
-rw-r--r--abs/extra/sqlite/PKGBUILD93
1 files changed, 93 insertions, 0 deletions
diff --git a/abs/extra/sqlite/PKGBUILD b/abs/extra/sqlite/PKGBUILD
new file mode 100644
index 0000000..062789e
--- /dev/null
+++ b/abs/extra/sqlite/PKGBUILD
@@ -0,0 +1,93 @@
+# $Id: PKGBUILD 161621 2012-06-12 15:12:59Z andyrtr $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgbase="sqlite"
+pkgname=('sqlite' 'sqlite-tcl' 'sqlite-doc')
+_amalgamationver=3071300
+_amalgamationver2=${_amalgamationver/00/}
+_docver=${_amalgamationver} #3070700
+#pkgver=${_amalgamationver2//0/.}
+pkgver=3.7.13
+pkgrel=1
+pkgdesc="A C library that implements an SQL database engine"
+arch=('i686' 'x86_64')
+license=('custom')
+url="http://www.sqlite.org/"
+makedepends=('tcl' 'readline')
+source=( # tarball containing the amalgamation for SQLite >= 3.7.5 together with a configure script and makefile for building it; includes now also the Tcl Extension Architecture (TEA)
+ http://www.sqlite.org/sqlite-autoconf-$_amalgamationver.tar.gz
+ #http://www.sqlite.org/sqlite-doc-${_amalgamationver}.zip
+ http://www.sqlite.org/sqlite-doc-${_docver}.zip
+ license.txt)
+options=('!libtool' '!emptydirs')
+md5sums=('c97df403e8a3d5b67bb408fcd6aabd8e'
+ '16a003d5a619a6c725e3d81cf5aaba2a'
+ 'c1cdbc5544034d9012e421e75a5e4890')
+
+build() {
+ export CFLAGS="$CFLAGS -DSQLITE_ENABLE_FTS3=1 -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_ENABLE_UNLOCK_NOTIFY -DSQLITE_SECURE_DELETE"
+
+ # build sqlite
+ cd "$srcdir"/sqlite-autoconf-$_amalgamationver
+ ./configure --prefix=/usr \
+ --disable-static
+ make
+
+ # build the tcl extension
+ cd "$srcdir"/sqlite-autoconf-$_amalgamationver/tea
+ ./configure --prefix=/usr \
+ --with-system-sqlite
+ make
+
+}
+
+package_sqlite() {
+
+ pkgdesc="A C library that implements an SQL database engine"
+ depends=('readline')
+ provides=("sqlite3=$pkgver")
+ replaces=("sqlite3")
+
+ cd ${srcdir}/sqlite-autoconf-$_amalgamationver
+ make DESTDIR=${pkgdir} install
+
+ # license
+ install -D -m644 ${srcdir}/license.txt ${pkgdir}/usr/share/licenses/${pkgname}/license.txt
+}
+
+package_sqlite-tcl() {
+
+ pkgdesc="sqlite Tcl Extension Architecture (TEA)"
+ depends=('sqlite')
+ provides=("sqlite3-tcl=$pkgver")
+ replaces=("sqlite3-tcl")
+
+ cd ${srcdir}/sqlite-autoconf-$_amalgamationver/tea
+ make DESTDIR=${pkgdir} install
+}
+
+package_sqlite-doc() {
+
+ pkgdesc="most of the static HTML files that comprise this website, including all of the SQL Syntax and the C/C++ interface specs and other miscellaneous documentation"
+ #arch=('any') - not yet supported
+ provides=("sqlite3-doc=$pkgver")
+ replaces=("sqlite3-doc")
+
+ #cd ${srcdir}/sqlite-doc-${_amalgamationver}
+ cd ${srcdir}/sqlite-doc-${_docver}
+ mkdir -p ${pkgdir}/usr/share/doc/${pkgbase}
+ cp -R * ${pkgdir}/usr/share/doc/${pkgbase}/
+
+ # fix permissions and remove obsolete files; https://bugs.archlinux.org/task/24605
+ find ${pkgdir} -type f -perm 755 -exec ls -lha {} \;
+ find ${pkgdir} -type f -perm 755 -exec chmod 644 {} \;
+
+ find ${pkgdir} -type f -name '*~' -exec ls -lha {} \;
+ find ${pkgdir} -type d -name '*~' -exec ls -lha {} \;
+ find ${pkgdir} -name '*~' -exec rm -f {} \;
+
+ find ${pkgdir} -type f -name '.~*' -exec ls -lha {} \; # /build/pkg/sqlite-doc/usr/share/doc/sqlite/images/fileformat/.~lock.indexpage.odg#
+ find ${pkgdir} -type d -name '.~*' -exec ls -lha {} \;
+ find ${pkgdir} -name '.~*' -exec rm -f {} \;
+}