summaryrefslogtreecommitdiffstats
path: root/abs/extra/strace/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/strace/PKGBUILD')
-rw-r--r--abs/extra/strace/PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/abs/extra/strace/PKGBUILD b/abs/extra/strace/PKGBUILD
new file mode 100644
index 0000000..c965f24
--- /dev/null
+++ b/abs/extra/strace/PKGBUILD
@@ -0,0 +1,21 @@
+# $Id: PKGBUILD 13699 2008-09-27 22:25:37Z giovanni $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+pkgname=strace
+pkgver=4.5.18
+pkgrel=1
+pkgdesc="A useful diagnositic, instructional, and debugging tool"
+arch=('i686' 'x86_64')
+license=('custom')
+url="http://sourceforge.net/projects/strace/"
+depends=('glibc')
+source=(http://downloads.sourceforge.net/sourceforge/strace/strace-$pkgver.tar.bz2)
+md5sums=('e9449fcee97e6a8ed73934c883c870e0')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+ install -Dm644 COPYRIGHT ${startdir}/pkg/usr/share/licenses/strace/COPYRIGHT
+}