summaryrefslogtreecommitdiffstats
path: root/abs/extra/swh-plugins/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/swh-plugins/PKGBUILD')
-rw-r--r--abs/extra/swh-plugins/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/extra/swh-plugins/PKGBUILD b/abs/extra/swh-plugins/PKGBUILD
new file mode 100644
index 0000000..69157a1
--- /dev/null
+++ b/abs/extra/swh-plugins/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 8773 2008-08-16 05:51:00Z eric $
+#Maintainer: Damir Perisa <damir.perisa@bluewin.ch>
+#Contributor: Robert Emil Berge
+
+pkgname=swh-plugins
+pkgver=0.4.15
+pkgrel=1
+pkgdesc="LADSPA Plugin-Collection from plugin.org.uk"
+arch=(i686 x86_64)
+url="http://plugin.org.uk/"
+depends=('fftw' 'ladspa')
+groups=('ladspa-plugins')
+source=(http://plugin.org.uk/releases/$pkgver/$pkgname-$pkgver.tar.gz)
+md5sums=('2fbdccef2462ea553901acd429fa3573')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+
+#Arch64 fix, -fPIC seems to be the only option
+if [ "$CARCH" = "x86_64" ]; then
+ export CFLAGS="$CFLAGS -fPIC"
+ export CXXFLAGS="$CFLAGS"
+fi
+
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+}