summaryrefslogtreecommitdiffstats
path: root/abs/extra/thunar/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/thunar/PKGBUILD')
-rw-r--r--abs/extra/thunar/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/abs/extra/thunar/PKGBUILD b/abs/extra/thunar/PKGBUILD
new file mode 100644
index 0000000..8086857
--- /dev/null
+++ b/abs/extra/thunar/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 28211 2009-02-28 11:12:20Z andyrtr $
+# Maintainer: tobias <tobias funnychar archlinux.org>
+# Contributor: Andrew Simmons <andrew.simmons@gmail.com>
+
+pkgname=thunar
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="new modern file manager for Xfce"
+arch=(i686 x86_64)
+license=('GPL2' 'LGPL2')
+url="http://thunar.xfce.org"
+groups=('xfce4')
+depends=('libexif>=0.6.17' 'hicolor-icon-theme' 'tango-icon-theme' )
+makedepends=('intltool' 'pkgconfig')
+optdepends=('gamin: a fam replacement to make thunar monitor changes to files on the fly')
+options=('!libtool')
+install=${pkgname}.install
+source=(http://www.xfce.org/archive/xfce-4.6.0/src/Thunar-${pkgver}.tar.bz2)
+md5sums=('468c240a4f65a217ec2b6132e85cd84e')
+
+build() {
+ cd ${srcdir}/Thunar-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
+ --localstatedir=/var --disable-static \
+ --disable-gnome-thumbnailers --enable-exif --enable-pcre --disable-fam
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+ sed -i 's:x-directory/gnome-default-handler;::' \
+ ${pkgdir}/usr/share/applications/Thunar-folder-handler.desktop
+}