summaryrefslogtreecommitdiffstats
path: root/abs/extra/unison/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/unison/PKGBUILD')
-rw-r--r--abs/extra/unison/PKGBUILD22
1 files changed, 19 insertions, 3 deletions
diff --git a/abs/extra/unison/PKGBUILD b/abs/extra/unison/PKGBUILD
index b1efa5b..6b3dc00 100644
--- a/abs/extra/unison/PKGBUILD
+++ b/abs/extra/unison/PKGBUILD
@@ -1,8 +1,8 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# $Id: PKGBUILD 57697 2009-11-01 15:08:02Z tpowa $
#Maintainer: Tobias Powalowski <tpowa@archlinux.org>
pkgname=unison
-pkgver=2.27.57
+pkgver=2.32.52
pkgrel=1
pkgdesc="Unison is a file-synchronization tool"
arch=(i686 x86_64)
@@ -10,6 +10,7 @@ license=('GPL2')
url="http://www.cis.upenn.edu/~bcpierce/unison"
depends=('glibc')
#makedepends=('ocaml' 'lablgtk' 'lablgtk2' 'imagemagick')
+#makedepends=('ocaml' 'imagemagick')
makedepends=('ocaml' )
source=(http://www.cis.upenn.edu/~bcpierce/unison/download/releases/stable/$pkgname-$pkgver.tar.gz \
$pkgname.desktop)
@@ -23,6 +24,21 @@ build() {
make UISTYLE=text DEBUGGING=false THREADS=true || return 1
mkdir -p $startdir/pkg/usr/bin
install -Dm755 unison $startdir/pkg/usr/bin/unison
+ # clean the builddir and rebuild with gtk support
+# make clean
+# make UISTYLE=gtk DEBUGGING=false THREADS=true || return 1
+# install -Dm755 unison $startdir/pkg/usr/bin/unison-gtk
+ # clean the builddir and rebuild with gtk2 support
+# make clean
+# make UISTYLE=gtk2 DEBUGGING=false THREADS=true || return 1
+# install -Dm755 unison $startdir/pkg/usr/bin/unison-gtk2
+ # install a .desktop file; create a compliant icon from ico file and install the png
+ # install -Dm644 ../$pkgname.desktop $startdir/pkg/usr/share/applications/$pkgname.desktop
+ # convert win32rc/U.ico unison.png
+ # install -Dm644 ${pkgname}-1.png $startdir/pkg/usr/share/pixmaps/$pkgname.png
+ # make symlink for .desktop file
+ # cd $startdir/pkg//usr/bin
+ # ln -s unison-gtk2 unison-x11
}
-md5sums=('4ba0a3e4bf4b4ad0c063f86391371f78'
+md5sums=('0701f095c1721776a0454b94607eda48'
'2daecba7705455a8e4b769e48b059872')