summaryrefslogtreecommitdiffstats
path: root/abs/extra/webkitgtk/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/webkitgtk/PKGBUILD')
-rw-r--r--abs/extra/webkitgtk/PKGBUILD100
1 files changed, 59 insertions, 41 deletions
diff --git a/abs/extra/webkitgtk/PKGBUILD b/abs/extra/webkitgtk/PKGBUILD
index 93a98cd..c0e836f 100644
--- a/abs/extra/webkitgtk/PKGBUILD
+++ b/abs/extra/webkitgtk/PKGBUILD
@@ -1,61 +1,79 @@
-# $Id: PKGBUILD 157142 2012-04-24 22:33:15Z ibiru $
+# $Id$
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
-pkgbase=libwebkit
-pkgname=(libwebkit libwebkit3)
-pkgver=1.8.1
+pkgbase=webkitgtk
+pkgname=(webkitgtk webkitgtk2)
+pkgver=2.4.7
pkgrel=1
-pkgdesc="An opensource web content engine"
-arch=('i686' 'x86_64')
+pkgdesc="GTK+ Web content engine library"
+arch=(i686 x86_64)
url="http://webkitgtk.org/"
-license=('custom')
-depends=('libxt' 'libxslt' 'sqlite' 'icu' 'gstreamer0.10-base' 'libsoup' 'enchant' 'libgl'
- 'geoclue')
-makedepends=('gperf' 'gobject-introspection' 'python2' 'gtk2' 'gtk3' 'mesa')
-options=('!libtool' '!emptydirs')
-source=(http://webkitgtk.org/releases/webkit-$pkgver.tar.xz webkit.patch)
+license=(custom)
+depends=(libxt libxslt sqlite libsoup enchant libgl geoclue gst-plugins-base-libs
+ libsecret libwebp harfbuzz-icu)
+makedepends=(gtk3 gtk2 gperf gobject-introspection python2 mesa ruby)
+optdepends=('gst-plugins-base: free media decoding'
+ 'gst-plugins-good: media decoding'
+ 'gst-libav: nonfree media decoding')
+options=(!emptydirs)
+source=(http://webkitgtk.org/releases/$pkgbase-${pkgver}.tar.xz
+ fix-pretty-quotes.patch)
+sha256sums=('f5cf26e39abf1d6b2d25f1398348fef6bbe6c03fb4f99e11c569091c05197d38'
+ '56316228bbbf0b7ebcbe210a35120f4e72cb9c1b680dd82cc2bde0f4549245e6')
-build() {
- cd "$srcdir/webkit-$pkgver"
- patch -Np1 < ../webkit.patch
- mkdir build-gtk{2,3}
+prepare() {
+ mkdir build-gtk{,2} path
- # clear makeflags: race during introspection.
- # WebKit*.gir should be created before WebKit*.typelib, but isn't
- MAKEFLAGS=
+ ln -s /usr/bin/python2 path/python
- ( cd build-gtk2 && _build --with-gtk=2.0 )
- ( cd build-gtk3 && _build --with-gtk=3.0 )
+ cd $pkgbase-$pkgver
+ patch -Np0 -i ../fix-pretty-quotes.patch
}
-_build() {
- PYTHON=/usr/bin/python2 ../configure --prefix=/usr \
+_build() (
+ _ver="$1"; shift
+ cd build-${_ver}
+
+ ../$pkgbase-$pkgver/configure --prefix=/usr \
+ --libexecdir=/usr/lib/webkit${_ver} \
--enable-introspection \
- --with-font-backend=freetype \
- --with-unicode-backend=icu \
- --enable-spellcheck "$@"
+ --disable-webkit2 \
+ --disable-gtk-doc \
+ "$@"
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
make all stamp-po
-}
+)
-package_libwebkit() {
- pkgdesc+=" (for GTK2)"
- depends+=(gtk2)
+build() {
+ PATH="$srcdir/path:$PATH"
- cd "$srcdir/webkit-$pkgver/build-gtk2"
- make DESTDIR="$pkgdir" install
- install -Dm644 ../Source/WebKit/LICENSE "$pkgdir/usr/share/licenses/libwebkit/LICENSE"
+ _build gtk
+ _build gtk2 --with-gtk=2.0
}
-package_libwebkit3() {
- pkgdesc+=" (for GTK3)"
+package_webkitgtk() {
depends+=(gtk3)
+ optdepends+=('gtk2: Netscape plugin support')
+ provides=("webkitgtk3=${pkgver}" "libwebkit3=${pkgver}")
+ conflicts=(webkitgtk3 libwebkit3)
+ replaces=(webkitgtk3 libwebkit3)
- cd "$srcdir/webkit-$pkgver/build-gtk3"
- make DESTDIR="$pkgdir" install
- install -Dm644 ../Source/WebKit/LICENSE "$pkgdir/usr/share/licenses/libwebkit3/LICENSE"
+ make -C build-gtk -j1 DESTDIR="$pkgdir" install
+ install -Dm644 $pkgbase-$pkgver/Source/WebKit/LICENSE \
+ "$pkgdir/usr/share/licenses/webkitgtk/LICENSE"
}
+package_webkitgtk2() {
+ pkgdesc+=" for GTK2"
+ depends+=(gtk2)
+ provides=("libwebkit=${pkgver}")
+ conflicts=(libwebkit)
+ replaces=(libwebkit)
-
-md5sums=('f2f01b1fdc7262a2eede81ebed0970b2'
- 'dab90271e918f48ed215648521d5a8a0')
+ make -C build-gtk2 -j1 DESTDIR="$pkgdir" install
+ install -Dm644 $pkgbase-$pkgver/Source/WebKit/LICENSE \
+ "$pkgdir/usr/share/licenses/webkitgtk2/LICENSE"
+}