summaryrefslogtreecommitdiffstats
path: root/abs/extra/windowmaker/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/windowmaker/PKGBUILD')
-rw-r--r--abs/extra/windowmaker/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/extra/windowmaker/PKGBUILD b/abs/extra/windowmaker/PKGBUILD
new file mode 100644
index 0000000..5422f87
--- /dev/null
+++ b/abs/extra/windowmaker/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 27785 2009-02-25 23:32:40Z eric $
+# Maintainer: aurelien <aurelien@archlinux.org>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+pkgname=windowmaker
+pkgver=0.92.0
+pkgrel=5
+pkgdesc="An X11 window manager with a NEXTSTEP look and feel"
+arch=(i686 x86_64)
+url="http://www.windowmaker.info/"
+license=('GPL' 'custom')
+depends=('libxinerama' 'libpng' 'libxpm' 'libxft' 'libtiff' 'giflib')
+options=('!libtool')
+source=(http://windowmaker.info/pub/source/release/WindowMaker-$pkgver.tar.bz2 windowmaker-gcc4.patch.tar.bz2)
+md5sums=('aaac5421b686ed2d3e6ab65229c98097' 'd9fb6a9c255f5c03d0e0c83dc3cd2320')
+
+build() {
+ cd $srcdir/WindowMaker-$pkgver
+ patch -Np1 -i ../windowmaker-gcc4.patch || return 1
+ libtoolize --force --copy || return 1
+ aclocal || return 1
+ autoconf || return 1
+ automake || return 1
+ [ -z "$LINGUAS" ] && export LINGUAS="`ls po/*.po | sed 's:po/\(.*\)\.po$:\1:'`"
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --with-gnustepdir=/usr/share/GNUstep --with-nlsdir=/usr/share/locale \
+ --enable-xinerama || return 1
+ make || return 1
+ make DESTDIR=$pkgdir install || return 1
+ install -D -m644 COPYING.WTFPL $pkgdir/usr/share/licenses/$pkgname/COPYING.WTFPL
+}
+