summaryrefslogtreecommitdiffstats
path: root/abs/extra/xbmc-svn/xbmc-svn.install
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/xbmc-svn/xbmc-svn.install')
-rw-r--r--abs/extra/xbmc-svn/xbmc-svn.install27
1 files changed, 21 insertions, 6 deletions
diff --git a/abs/extra/xbmc-svn/xbmc-svn.install b/abs/extra/xbmc-svn/xbmc-svn.install
index acf409c..9d24167 100644
--- a/abs/extra/xbmc-svn/xbmc-svn.install
+++ b/abs/extra/xbmc-svn/xbmc-svn.install
@@ -1,13 +1,28 @@
post_install() {
- echo ">> If XBMC won't start, but just segfaults, double check your X.Org config"
- echo ">> so that your display depth is at least 24-bit. Eg: change "
- echo ">> \"DefaultDepth 16\" under the \"Screen\" section so it says 24 instead"
- echo ">> of 16."
+ echo ">> If XBMC won't start, but just segfaults, double check your X.Org config."
+ echo ">> The display depth has to be at least 24-bit, ie"
+ echo ">> set \"DefaultDepth 24\" under the \"Screen\" section of your xorg.conf file."
echo ">> If you have problems or suggestions for this PKGBUILD, have a look at its"
echo ">> dedicated forum thread: http://bbs.archlinux.org/viewtopic.php?pid=559107"
- echo ">> or the wiki: http://xbmc.org/wiki/?title=XBMC_on_Arch_Linux_(Unofficial)"
+ echo ">> or the wiki: http://xbmc.org/wiki/?title=XBMC_on_Arch_Linux_(Unofficial)."
+ echo ">> Note that this is a development version of XBMC."
+ echo ">> If you encounter problems with XBMC don't forget to consult the official"
+ echo ">> xbmc forums found here: http://forum.xbmc.org "
+ echo ">> and report bugs to the xbmc bugtracker found here: http://trac.xbmc.org."
echo
- /bin/true
+
+ [[ $(type -p gtk-update-icon-cache) ]] && /usr/bin/gtk-update-icon-cache -qtf usr/share/icons/hicolor
+ [[ $(type -p update-desktop-database) ]] && /usr/bin/update-desktop-database -q usr/share/applications
+}
+
+post_upgrade() {
+ [[ $(type -p gtk-update-icon-cache) ]] && /usr/bin/gtk-update-icon-cache -qtf usr/share/icons/hicolor
+ [[ $(type -p update-desktop-database) ]] && /usr/bin/update-desktop-database -q usr/share/applications
+}
+
+post_remove() {
+ [[ $(type -p gtk-update-icon-cache) ]] && /usr/bin/gtk-update-icon-cache -qtf usr/share/icons/hicolor
+ [[ $(type -p update-desktop-database) ]] && /usr/bin/update-desktop-database -q usr/share/applications
}
# vim:set ts=2 sw=2 et: