summaryrefslogtreecommitdiffstats
path: root/abs/extra/xbmc/xbmc.install
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/xbmc/xbmc.install')
-rw-r--r--abs/extra/xbmc/xbmc.install30
1 files changed, 9 insertions, 21 deletions
diff --git a/abs/extra/xbmc/xbmc.install b/abs/extra/xbmc/xbmc.install
index 46ac150..6490483 100644
--- a/abs/extra/xbmc/xbmc.install
+++ b/abs/extra/xbmc/xbmc.install
@@ -1,29 +1,17 @@
post_install() {
- gen_lib_xml.py
- echo ">> If XBMC won't start, but just segfaults, double check your X.Org config."
- echo ">> The display depth has to be at least 24-bit, ie"
- echo ">> set \"DefaultDepth 24\" under the \"Screen\" section of your xorg.conf file."
- echo ">> If you have problems or suggestions for this PKGBUILD, have a look at its"
- echo ">> dedicated forum thread: http://bbs.archlinux.org/viewtopic.php?pid=559107"
- echo ">> or the wiki: http://xbmc.org/wiki/?title=XBMC_on_Arch_Linux_(Unofficial)."
- echo ">> Note that this is a development version of XBMC."
- echo ">> If you encounter problems with XBMC don't forget to consult the official"
- echo ">> xbmc forums found here: http://forum.xbmc.org "
- echo ">> and report bugs to the xbmc bugtracker found here: http://trac.xbmc.org."
- echo
-
- [[ $(type -p gtk-update-icon-cache) ]] && /usr/bin/gtk-update-icon-cache -qtf usr/share/icons/hicolor
- [[ $(type -p update-desktop-database) ]] && /usr/bin/update-desktop-database -q usr/share/applications
+ [[ $(type -p gtk-update-icon-cache) ]] && usr/bin/gtk-update-icon-cache -qtf usr/share/icons/hicolor
+ [[ $(type -p update-desktop-database) ]] && usr/bin/update-desktop-database -q usr/share/applications
+ getent group xbmc > /dev/null || groupadd xbmc
+ getent passwd xbmc > /dev/null || useradd -m -d /var/lib/xbmc -g xbmc xbmc
+ usermod -a -G xbmc,audio,video,power,network,optical,storage,disk xbmc
+ gen_lib_xml.py
}
post_upgrade() {
- gen_lib_xml.py
- [[ $(type -p gtk-update-icon-cache) ]] && /usr/bin/gtk-update-icon-cache -qtf usr/share/icons/hicolor
- [[ $(type -p update-desktop-database) ]] && /usr/bin/update-desktop-database -q usr/share/applications
+ post_install $1
}
post_remove() {
- [[ $(type -p gtk-update-icon-cache) ]] && /usr/bin/gtk-update-icon-cache -qtf usr/share/icons/hicolor
- [[ $(type -p update-desktop-database) ]] && /usr/bin/update-desktop-database -q usr/share/applications
- gen_lib_xml.py
+ post_install $1
+ echo "You may want to remove xbmc user and group"
}