summaryrefslogtreecommitdiffstats
path: root/abs/extra/xine-lib/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/xine-lib/PKGBUILD')
-rw-r--r--abs/extra/xine-lib/PKGBUILD55
1 files changed, 32 insertions, 23 deletions
diff --git a/abs/extra/xine-lib/PKGBUILD b/abs/extra/xine-lib/PKGBUILD
index aa15b8f..7273e1a 100644
--- a/abs/extra/xine-lib/PKGBUILD
+++ b/abs/extra/xine-lib/PKGBUILD
@@ -1,41 +1,50 @@
-# $Id: PKGBUILD 26791 2009-02-12 02:31:16Z eric $
+# $Id: PKGBUILD 91275 2010-09-25 21:56:25Z eric $
# Maintainer: Eric Belanger <eric@archlinux.org>
# Contributor: Judd Vinet <jvinet@zeroflux.org>
pkgname=xine-lib
-pkgver=1.1.16.3
-pkgrel=4
-pkgdesc="A free video player for Unix"
+pkgver=1.1.19
+pkgrel=1
+pkgdesc="A multimedia playback engine"
arch=('i686' 'x86_64')
-url="http://xinehq.de/"
-install=xine.install
+url="http://www.xine-project.org"
license=('LGPL' 'GPL')
-depends=('libgl' 'libxvmc' 'flac>=1.1.4' 'libvorbis' 'sdl' 'libmng' 'libtheora'
- 'libxcb' 'wavpack' 'ffmpeg>=20081220' 'heimdal>=1.2.1')
-makedepends=('pkgconfig' 'libtool' 'imagemagick' 'smbclient' 'mesa' 'alsa-lib'
- 'vcdimager' )
+install=xine.install
+depends=('libgl' 'libxvmc' 'flac' 'libvorbis' 'sdl' 'libmng' 'libtheora'
+ 'libxcb' 'wavpack' 'ffmpeg' 'heimdal' 'faad2')
+makedepends=('pkg-config' 'libtool' 'imagemagick' 'smbclient' 'mesa' 'alsa-lib'
+ 'vcdimager' 'gtk2')
+optdepends=('imagemagick: for using the imagemagick plugin' 'smbclient: for using the smb plugin' \
+ 'gtk2: for using the gdk-pixbuf plugin' 'mesa: for using the opengl plugin')
options=('!libtool')
+#changelog=ChangeLog
source=(http://downloads.sourceforge.net/sourceforge/xine/${pkgname}-${pkgver}.tar.bz2
- xine-lib-1.1.1-configure-no-mcpu-march.patch)
-md5sums=('4f508abf088cf427a731f85634c8260d'
- '9776df4eb54d2f1f68d8268adbc3b5c2')
-optiona=(!emptydir)
+ xine-lib-1.1.1-configure-no-mcpu-march.patch xine-lib-1.1.19-xvmc.patch)
+md5sums=('a410a0f0617e1d6309f0cbe907f73f8a' '9776df4eb54d2f1f68d8268adbc3b5c2'\
+ '8662fb124870b1dd7effe4ff5e2a2e3d')
+sha1sums=('5afcc28c5cf2bdaab99d951960f6587797e1e5a0' '121a8358d7919b2e51067412373f52848290338a'\
+ '920bf27e6e3523dfe4cc9c802ff713e9688a3f34')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- patch -p0 < ../xine-lib-1.1.1-configure-no-mcpu-march.patch || return 1
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p0 < ../xine-lib-1.1.1-configure-no-mcpu-march.patch
+ patch -p0 < ../xine-lib-1.1.19-xvmc.patch
- libtoolize --force --copy || return 1
- aclocal -I m4 || return 1
- autoconf || return 1
- automake --add-missing || return 1
+ libtoolize --force --copy
+ aclocal -I m4
+ autoconf
+ automake --add-missing
./configure --prefix=/usr --with-w32-path=/usr/lib/codecs \
--with-xv-path=/usr/lib --with-xxmc-path=/usr/lib --with-xvmc-path=/usr/lib \
--with-libflac --with-wavpack --with-xcb \
--without-arts --without-jack --without-speex \
--disable-gnomevfs --without-pulseaudio --disable-aalib \
- --disable-modplug --with-external-ffmpeg --without-esd || return 1
- make || return 1
- make DESTDIR=${pkgdir} install || return 1
+ --disable-modplug --with-external-ffmpeg
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}