summaryrefslogtreecommitdiffstats
path: root/abs/extra/xine-lib/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/xine-lib/PKGBUILD')
-rw-r--r--abs/extra/xine-lib/PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/abs/extra/xine-lib/PKGBUILD b/abs/extra/xine-lib/PKGBUILD
new file mode 100644
index 0000000..aa15b8f
--- /dev/null
+++ b/abs/extra/xine-lib/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id: PKGBUILD 26791 2009-02-12 02:31:16Z eric $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+
+pkgname=xine-lib
+pkgver=1.1.16.3
+pkgrel=4
+pkgdesc="A free video player for Unix"
+arch=('i686' 'x86_64')
+url="http://xinehq.de/"
+install=xine.install
+license=('LGPL' 'GPL')
+depends=('libgl' 'libxvmc' 'flac>=1.1.4' 'libvorbis' 'sdl' 'libmng' 'libtheora'
+ 'libxcb' 'wavpack' 'ffmpeg>=20081220' 'heimdal>=1.2.1')
+makedepends=('pkgconfig' 'libtool' 'imagemagick' 'smbclient' 'mesa' 'alsa-lib'
+ 'vcdimager' )
+options=('!libtool')
+source=(http://downloads.sourceforge.net/sourceforge/xine/${pkgname}-${pkgver}.tar.bz2
+ xine-lib-1.1.1-configure-no-mcpu-march.patch)
+md5sums=('4f508abf088cf427a731f85634c8260d'
+ '9776df4eb54d2f1f68d8268adbc3b5c2')
+optiona=(!emptydir)
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ patch -p0 < ../xine-lib-1.1.1-configure-no-mcpu-march.patch || return 1
+
+ libtoolize --force --copy || return 1
+ aclocal -I m4 || return 1
+ autoconf || return 1
+ automake --add-missing || return 1
+
+ ./configure --prefix=/usr --with-w32-path=/usr/lib/codecs \
+ --with-xv-path=/usr/lib --with-xxmc-path=/usr/lib --with-xvmc-path=/usr/lib \
+ --with-libflac --with-wavpack --with-xcb \
+ --without-arts --without-jack --without-speex \
+ --disable-gnomevfs --without-pulseaudio --disable-aalib \
+ --disable-modplug --with-external-ffmpeg --without-esd || return 1
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+}