summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/htop/PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/abs/extra/htop/PKGBUILD b/abs/extra/htop/PKGBUILD
index 93b4db6..1ba9d94 100644
--- a/abs/extra/htop/PKGBUILD
+++ b/abs/extra/htop/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 170397 2012-11-07 01:25:17Z dreisner $
+# $Id$
# Maintainer: Angel Velasquez <angvp@archlinux.org>
# Contributor: Eric Belanger <eric@archlinux.org>
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=htop
-pkgver=1.0.2
+pkgver=1.0.3
pkgrel=1
pkgdesc="Interactive process viewer"
arch=('i686' 'x86_64')
@@ -15,14 +15,18 @@ makedepends=('python2')
optdepends=('lsof: show files opened by a process'
'strace: attach to a running process')
options=('!emptydirs')
-source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
-md5sums=('0d01cca8df3349c74569cefebbd9919e')
+source=("http://hisham.hm/$pkgname/releases/$pkgver/$pkgname-$pkgver.tar.gz")
+md5sums=('e768b9b55c033d9c1dffda72db3a6ac7')
-build() {
+prepare() {
cd "$pkgname-$pkgver"
sed -i 's|ncursesw/curses.h|curses.h|' RichString.[ch] configure
sed -i 's|python|python2|' scripts/MakeHeader.py
+}
+
+build() {
+ cd "$pkgname-$pkgver"
./configure \
--prefix=/usr \