summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/ghosd/ghosd-0.0.1/ghosd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'abs/mv-core/ghosd/ghosd-0.0.1/ghosd/Makefile.am')
-rw-r--r--abs/mv-core/ghosd/ghosd-0.0.1/ghosd/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/abs/mv-core/ghosd/ghosd-0.0.1/ghosd/Makefile.am b/abs/mv-core/ghosd/ghosd-0.0.1/ghosd/Makefile.am
new file mode 100644
index 0000000..92b9611
--- /dev/null
+++ b/abs/mv-core/ghosd/ghosd-0.0.1/ghosd/Makefile.am
@@ -0,0 +1,24 @@
+lib_LTLIBRARIES = libghosd.la
+
+INCLUDES = $(GHOSD_CFLAGS)
+libghosd_la_LDFLAGS = -version-info @VERSION_INFO@
+libghosd_la_LIBADD = $(GHOSD_LIBS)
+libghosd_la_includedir = $(includedir)/ghosd-1.0/ghosd
+
+headers = ghosd.h
+# ghosd-internal.h is in SOURCES not HEADERS because we don't
+# want to install it into /usr/include/.../
+sources = ghosd-internal.h ghosd.c ghosd-main.c
+
+pango_headers = ghosd-text.h
+pango_sources = ghosd-text.c
+
+if PANGO
+libghosd_la_SOURCES = $(sources) $(pango_sources)
+libghosd_la_include_HEADERS = $(headers) $(pango_headers)
+else
+libghosd_la_SOURCES = $(sources)
+libghosd_la_include_HEADERS = $(headers)
+endif
+
+# vim: set ts=2 sw=2 et cino=(0 :