summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/myth/stable/mythphone/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/mv-core/myth/stable/mythphone/PKGBUILD')
-rw-r--r--abs/mv-core/myth/stable/mythphone/PKGBUILD42
1 files changed, 0 insertions, 42 deletions
diff --git a/abs/mv-core/myth/stable/mythphone/PKGBUILD b/abs/mv-core/myth/stable/mythphone/PKGBUILD
deleted file mode 100644
index 7fd3b46..0000000
--- a/abs/mv-core/myth/stable/mythphone/PKGBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-pkgname=mythphone-release-fixes
-pkgver=21228
-pkgrel=1
-pkgdesc="Plugin that allows phone calls to be made to MythTv"
-url="http://www.mythtv.org"
-arch=('i686')
-depends=('mythtv-release-fixes')
-conflicts=('mythtv-plugins-release-fixes')
-groups=('mythtv-all-plugins-release-fixes')
-license="GPL"
-source=()
-_svntrunk=http://svn.mythtv.org/svn/branches/release-0-21-fixes/mythplugins
-_svntrunk=http://svn.mythtv.org/svn/branches/release-0-21-fixes/mythplugins
-_svnmod=mythplugins
-
-build() {
- cd $startdir/src/
- echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
- svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
- cd $startdir/src/mythplugins
- make distclean
- PLUGIN=mythphone
- grep -q programs-libs.pro $PLUGIN/$PLUGIN/$PLUGIN.pro
- if [ $? != 0 ]
- then
- echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
- msg "appending program lib"
- fi
-
- msg "Correcting configure kde3 to kde"
- sed -i 's#kde3#kde#' configure || return 1
- ./configure --prefix=/usr --enable-opengl --disable-all --enable-mythphone || return 1
- qmake mythplugins.pro || return 1
- make qmake || return 1
-
- msg "Correcting Makefile kde3 to kde"
- sed -i 's#kde3#kde#' ./mythphone/mythphone/Makefile || return 1
-
- make -j 2 || return 1
- make INSTALL_ROOT=$startdir/pkg install
-}
-