summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/myth/stable/mythweb
diff options
context:
space:
mode:
Diffstat (limited to 'abs/mv-core/myth/stable/mythweb')
-rwxr-xr-xabs/mv-core/myth/stable/mythweb/PKGBUILD34
-rwxr-xr-xabs/mv-core/myth/stable/mythweb/dblogininit.inc6
-rwxr-xr-xabs/mv-core/myth/stable/mythweb/mythweb.install37
-rwxr-xr-xabs/mv-core/myth/stable/mythweb/mythweblighttpd.patch13
4 files changed, 0 insertions, 90 deletions
diff --git a/abs/mv-core/myth/stable/mythweb/PKGBUILD b/abs/mv-core/myth/stable/mythweb/PKGBUILD
deleted file mode 100755
index 52341a4..0000000
--- a/abs/mv-core/myth/stable/mythweb/PKGBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-pkgname=mythweb-release-fixes
-pkgver=21228
-pkgrel=1
-pkgdesc="mythweb"
-url="http://www.mythtv.org"
-license="GPL"
-arch=('i686')
-depends=(php fcgi libmysqlclient )
-conflicts=('mythweb' 'mythweb-fixes')
-replaces=()
-backup=()
-install='mythweb.install'
-source=(mythweblighttpd.patch dblogininit.inc )
-md5sums=()
-_svntrunk=http://svn.mythtv.org/svn/branches/release-0-21-fixes/mythplugins
-_svnmod=mythplugins
-build() {
-echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
- svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
-#svn co http://cvs.mythtv.org/svn/trunk/mythtv
-#svn co http://cvs.mythtv.org/svn/trunk/mythplugins
-#svn co http://cvs.mythtv.org/svn/trunk/myththemes
-cd $startdir/src/mythplugins
-
-#take care of fing mythweb
-mkdir -p $startdir/pkg/data/srv/httpd/htdocs/
-cp -rp mythweb $startdir/pkg/data/srv/httpd/htdocs/
-cp -f $startdir/src/dblogininit.inc $startdir/pkg/data/srv/httpd/htdocs/mythweb/includes/
-cd $startdir/pkg/data/srv/httpd/htdocs/mythweb/includes
-patch -p0 < $startdir/src/mythweblighttpd.patch
-
-chown -R nobody:nobody $startdir/pkg/data/srv/httpd/htdocs/mythweb
-chmod -R 775 $startdir/pkg/data/srv/httpd/htdocs/mythweb
-}
diff --git a/abs/mv-core/myth/stable/mythweb/dblogininit.inc b/abs/mv-core/myth/stable/mythweb/dblogininit.inc
deleted file mode 100755
index c5395c5..0000000
--- a/abs/mv-core/myth/stable/mythweb/dblogininit.inc
+++ /dev/null
@@ -1,6 +0,0 @@
-<?
- $_SERVER["db_server"] = "localhost";
- $_SERVER["db_name"] = "mythconverg";
- $_SERVER["db_login"] = "mythtv";
- $_SERVER["db_password"] = "mythtv";
-?>
diff --git a/abs/mv-core/myth/stable/mythweb/mythweb.install b/abs/mv-core/myth/stable/mythweb/mythweb.install
deleted file mode 100755
index e135b6c..0000000
--- a/abs/mv-core/myth/stable/mythweb/mythweb.install
+++ /dev/null
@@ -1,37 +0,0 @@
-
-# arg 1: the new package version
-pre_install () {
-/bin/true
-}
-
-post_install() {
- #cp /etc/lighttpd/lighttpd.conf /tmp
-# sed -e "s/# .* \"mod_fastcgi\",/\"mod_fastcgi\"\,/g" /tmp/lighttpd.conf > /etc/lighttpd/lighttpd.conf
- /bin/true
-
-}
-pre_upgrade () {
- pre_install
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- post_install
-
- /bin/true
-}
-
-# arg 1: the old package version
-pre_remove() {
- /bin/true
-}
-
-# arg 1: the old package version
-post_remove() {
-/bint/true
-}
-
-op=$1
-shift
-$op $*
diff --git a/abs/mv-core/myth/stable/mythweb/mythweblighttpd.patch b/abs/mv-core/myth/stable/mythweb/mythweblighttpd.patch
deleted file mode 100755
index 6403a88..0000000
--- a/abs/mv-core/myth/stable/mythweb/mythweblighttpd.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- database.php.orig 2007-12-31 21:25:30.000000000 +0000
-+++ database.php 2007-12-31 21:25:50.000000000 +0000
-@@ -18,6 +18,10 @@
- custom_error("Please install the MySQL libraries for PHP.\n"
- .'The package is usually called something like php-mysql.');
- }
-+ if (empty($_SERVER['db_server']) || empty($_SERVER['db_name']) || empty($_SERVER['db_login'])) {
-+ require_once 'dblogininit.inc';
-+ }
-+
-
- // No database connection info defined?
- if (empty($_SERVER['db_server']) || empty($_SERVER['db_name']) || empty($_SERVER['db_login'])) {