summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/libxfontcache/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/core/libxfontcache/PKGBUILD')
-rw-r--r--abs/not_built/core/libxfontcache/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/not_built/core/libxfontcache/PKGBUILD b/abs/not_built/core/libxfontcache/PKGBUILD
new file mode 100644
index 0000000..0f01a34
--- /dev/null
+++ b/abs/not_built/core/libxfontcache/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 55250 2009-10-12 16:05:23Z andyrtr $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=libxfontcache
+pkgver=1.0.5
+pkgrel=2
+pkgdesc="X11 font cache library"
+arch=('i686' 'x86_64')
+url="http://xorg.freedesktop.org/"
+license=('custom')
+depends=('libxext' 'fontcacheproto')
+makedepends=('pkgconfig')
+options=('!libtool')
+source=(${url}/releases/individual/lib/libXfontcache-${pkgver}.tar.bz2 LICENSE)
+
+build() {
+ cd ${srcdir}/libXfontcache-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc --disable-static \
+ --build=${CHOST} --host=${CHOST}
+ make || return 1
+}
+package() {
+ cd ${srcdir}/libXfontcache-${pkgver}
+ make DESTDIR=${pkgdir} install || return 1
+ install -D -m644 ../LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+md5sums=('bbd37768c87f63cf2eb845b2c0f56515'
+ '9738fb66a1a69ce086c461d5bedc7d8f')