summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/mcpp/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/core/mcpp/PKGBUILD')
-rw-r--r--abs/not_built/core/mcpp/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/not_built/core/mcpp/PKGBUILD b/abs/not_built/core/mcpp/PKGBUILD
new file mode 100644
index 0000000..57dae67
--- /dev/null
+++ b/abs/not_built/core/mcpp/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 22398 2008-12-26 17:32:45Z jgc $
+# Maintainer: Alexander Baldeck <alexander@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+pkgname=mcpp
+pkgver=2.7.2
+pkgrel=1
+pkgdesc="Matsui's CPP implementation precisely conformed to standards"
+arch=(i686 x86_64)
+license=('custom')
+url="http://mcpp.sourceforge.net"
+source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz )
+depends=(glibc)
+md5sums=('512de48c87ab023a69250edc7a0c7b05')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -sf ../doc/${pkgname}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/"
+}