summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/mythtv/stable-0.24/myththemes/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/core/mythtv/stable-0.24/myththemes/PKGBUILD')
-rw-r--r--abs/not_built/core/mythtv/stable-0.24/myththemes/PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/abs/not_built/core/mythtv/stable-0.24/myththemes/PKGBUILD b/abs/not_built/core/mythtv/stable-0.24/myththemes/PKGBUILD
new file mode 100644
index 0000000..96fa147
--- /dev/null
+++ b/abs/not_built/core/mythtv/stable-0.24/myththemes/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id: PKGBUILD 86938 2010-08-06 21:53:33Z ibiru $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: kleptophobiac@gmail.com
+
+pkgname=myththemes
+pkgver=0.24
+pkgrel=9
+pkgdesc="Themes for MythTV"
+arch=('any')
+url="http://www.mythtv.org/"
+license=('GPL')
+depends=("mythtv>=${pkgver}")
+source=('ftp://ftp.knoppmyth.net/R6/sources/myththemes-0.24-fixes.tar.bz2' `echo ${patches[@]:0}`)
+_gitroot="https://github.com/MythTV/myththemes.git"
+_gitname="${pkgname}"
+build() {
+ cd $srcdir/myththemes
+ git pull
+ rm -fr Mythbuntu
+ # apply patches
+ echo "--------------------------applying patches----------------------------------------------------"
+ for i in `echo ${patchs[@]:0} `
+ do
+ echo applying $i
+ echo "-----------------------------"
+ patch -Np0 -i ${startdir}/src/$i || return 1
+ done
+ echo "--------------------------done applying patches-----------------------------------------------"
+
+ cd "${srcdir}/${pkgname}"
+ ./configure --prefix=/usr || return 1
+}
+package() {
+ cd "${srcdir}/${pkgname}"
+ make INSTALL_ROOT="${pkgdir}" install || return 1
+}
+md5sums=('a5c9475a6d29c313cd9ae77566ee277a')