summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/mythtv/stable-0.24/mythweb/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/core/mythtv/stable-0.24/mythweb/PKGBUILD')
-rw-r--r--abs/not_built/core/mythtv/stable-0.24/mythweb/PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/abs/not_built/core/mythtv/stable-0.24/mythweb/PKGBUILD b/abs/not_built/core/mythtv/stable-0.24/mythweb/PKGBUILD
new file mode 100644
index 0000000..cab8fbd
--- /dev/null
+++ b/abs/not_built/core/mythtv/stable-0.24/mythweb/PKGBUILD
@@ -0,0 +1,46 @@
+pkgname=mythweb
+pkgver=0.24
+pkgrel=16
+pkgdesc="Web interface for MythTV's backend"
+url="http://www.mythtv.org"
+license="GPL"
+arch=('i686' 'x86_64')
+
+depends=('mythtv>=0.24' 'lighttpd' 'php' 'local-website')
+groups=('mythtv-extras')
+
+patches=()
+source=('ftp://ftp.knoppmyth.net/R6/sources/mythweb-0.24-fixes.tar.bz2' `echo ${patches[@]:0}`)
+
+DOCROOT=/data/srv/httpd/htdocs/mythweb
+_gitroot="https://github.com/mythtv/mythweb.git"
+_gitname="${pkgname}"
+build() {
+
+ cd $startdir/src/mythweb
+ git pull
+
+ echo "--------------------------applying patches----------------------------------------------------"
+ for i in `echo ${patches[@]:0} `
+ do
+ echo applying $i
+ echo "-----------------------------"
+ patch -Np0 -i ${srcdir}/$i || return 1
+ done
+ echo "--------------------------done applying patches-----------------------------------------------"
+
+ [ "$CARCH" = "i686" ] && ARCH="i686"
+ [ "$CARCH" = "x86_64" ] && ARCH="x86-64"
+
+ mkdir -p $startdir/pkg/$DOCROOT/{image_cache,php_sessions,data}
+ rsync -arp --exclude .git --delete-excluded $startdir/src/mythweb/* $startdir/pkg/$DOCROOT
+ rm $startdir/pkg/$DOCROOT/README
+ chown -R http:http $startdir/pkg/$DOCROOT
+ chmod g+rw $pkgdir/$DOCROOT/{image_cache,php_sessions,data}
+
+ # mythweb modules_path fix for 0.24
+ # http://code.mythtv.org/trac/ticket/9255
+ cd ${pkgdir}/${DOCROOT}
+ ln -s modules modules_path
+}
+md5sums=('45703fa3899c4ee84d1b087bfcc6654e')