summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/ntfs-3g/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/core/ntfs-3g/PKGBUILD')
-rw-r--r--abs/not_built/core/ntfs-3g/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/not_built/core/ntfs-3g/PKGBUILD b/abs/not_built/core/ntfs-3g/PKGBUILD
new file mode 100644
index 0000000..03a7168
--- /dev/null
+++ b/abs/not_built/core/ntfs-3g/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 94455 2010-10-07 10:35:38Z ronald $
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
+# Contributor: Thomas Bächler <thomas.archlinux.org>
+
+pkgname=ntfs-3g
+pkgver=2010.10.2
+pkgrel=1
+pkgdesc="Stable read and write NTFS driver"
+url="http://www.tuxera.com"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('glibc' 'fuse')
+makedepends=('pkgconfig')
+options=('!libtool')
+source=(http://www.tuxera.com/opensource/${pkgname}-${pkgver}.tgz
+ 25-ntfs-config-write-policy.fdi)
+sha1sums=('97531dc0e556596e6bf2169863e9b8368c7d2bd0'
+ '200029f2999a2c284fd30ae25734abf6459c3501')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ac_cv_path_LDCONFIG=/bin/true ./configure --prefix=/usr \
+ --with-fuse=external --disable-static
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ ln -s /bin/ntfs-3g "${pkgdir}/sbin/mount.ntfs"
+ install -m755 -d "${pkgdir}/usr/share/hal/fdi/policy/10osvendor"
+ install -m644 "${srcdir}/25-ntfs-config-write-policy.fdi" "${pkgdir}/usr/share/hal/fdi/policy/10osvendor/"
+}