summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/perl_modules/perl-getopt-lucid/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/core/perl_modules/perl-getopt-lucid/PKGBUILD')
-rw-r--r--abs/not_built/core/perl_modules/perl-getopt-lucid/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/not_built/core/perl_modules/perl-getopt-lucid/PKGBUILD b/abs/not_built/core/perl_modules/perl-getopt-lucid/PKGBUILD
new file mode 100644
index 0000000..9905900
--- /dev/null
+++ b/abs/not_built/core/perl_modules/perl-getopt-lucid/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=perl-getopt-lucid
+_realname=Getopt-Lucid
+pkgver=0.17
+pkgrel=1
+pkgdesc="Perl/CPAN Getopt::Lucid - Clear, readable syntax for command line processing"
+url="http://search.cpan.org/dist/${_realname}/"
+arch=(i686 x86_64)
+license=('PerlArtistic' 'GPL')
+depends=('perl>=5.10.0')
+options=('!emptydirs')
+#http://search.cpan.org/CPAN/authors/id/D/DA/DAGOLDEN/Getopt-Lucid-0.17.tar.gz
+
+source=(http://search.cpan.org/CPAN/authors/id/D/DA/DAGOLDEN/${_realname}-${pkgver}.tar.gz)
+
+build() {
+ cd ${startdir}/src/${_realname}-${pkgver}
+ # install module in vendor directories.
+ perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make install DESTDIR=${startdir}/pkg || return 1
+
+ # remove perllocal.pod and .packlist
+ find ${startdir}/pkg -name perllocal.pod -delete
+ find ${startdir}/pkg -name .packlist -delete
+}