summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/perl_modules/perl-javascript/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/core/perl_modules/perl-javascript/PKGBUILD')
-rw-r--r--abs/not_built/core/perl_modules/perl-javascript/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/not_built/core/perl_modules/perl-javascript/PKGBUILD b/abs/not_built/core/perl_modules/perl-javascript/PKGBUILD
new file mode 100644
index 0000000..5be227c
--- /dev/null
+++ b/abs/not_built/core/perl_modules/perl-javascript/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=perl-javascript
+pkgver=1.16
+pkgrel=2
+pkgdesc="Perl extension for executing embedded JavaScript"
+depends=('perl>=5.10.0' 'glibc' 'perl-test-exception' 'js<=1:1.7.0' 'xulrunner' 'nspr')
+license=('GPL' 'PerlArtistic')
+url="http://search.cpan.org/dist/JavaScript/"
+source=(http://search.cpan.org/CPAN/authors/id/C/CL/CLAESJAC/JavaScript-$pkgver.tar.gz)
+options=('!emptydirs')
+arch=(i686 x86_64)
+
+build()
+{
+ cd ${srcdir}/JavaScript-$pkgver
+
+ # dirty hack to pass the correct includes to the script
+ export JS_THREADSAFE=1 JS_UTF8=1 JS_ENABLE_E4X=1 JS_INC="/usr/include/js -I/usr/include/xulrunner-1.9.2 -I/usr/include/nspr"
+ perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+
+ # Remove .packlist and perllocal.pod files.
+ find ${pkgdir} -name '.packlist' -delete
+ find ${pkgdir} -name 'perllocal.pod' -delete
+
+}
+
+md5sums=('c3c4a744e0a5018b94f53341baa18df7')