summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/perl_modules/perl-pathtools/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/core/perl_modules/perl-pathtools/PKGBUILD')
-rw-r--r--abs/not_built/core/perl_modules/perl-pathtools/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/not_built/core/perl_modules/perl-pathtools/PKGBUILD b/abs/not_built/core/perl_modules/perl-pathtools/PKGBUILD
new file mode 100644
index 0000000..a88a231
--- /dev/null
+++ b/abs/not_built/core/perl_modules/perl-pathtools/PKGBUILD
@@ -0,0 +1,23 @@
+
+pkgname=perl-pathtools
+pkgver=3.33
+pkgrel=1
+pkgdesc="Current working directory (CWD) and File::Spec perl modules"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~KWILLIAMS/Path-Class"
+
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0')
+options=('!emptydirs')
+source=(http://search.cpan.org/CPAN/authors/id/S/SM/SMUELLER/PathTools-$pkgver.tar.gz)
+groups=('shepherd-dep')
+build() {
+ cd $startdir/src/PathTools-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make install DESTDIR=$startdir/pkg || return 1
+ find $startdir/pkg -name '.packlist' -delete
+ find $startdir/pkg -name '*.pod' -delete
+}
+
+md5sums=('92f0df032c399fadef2e2e647ebc3111')