summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/perl_modules/perl-proc-processtable/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/core/perl_modules/perl-proc-processtable/PKGBUILD')
-rw-r--r--abs/not_built/core/perl_modules/perl-proc-processtable/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/not_built/core/perl_modules/perl-proc-processtable/PKGBUILD b/abs/not_built/core/perl_modules/perl-proc-processtable/PKGBUILD
new file mode 100644
index 0000000..51ee46b
--- /dev/null
+++ b/abs/not_built/core/perl_modules/perl-proc-processtable/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Lukas Fleischer <archlinux at cryptocrack dot de>
+# Contributor: yugrotavele <yugrotavele at archlinux dot us>
+
+pkgname=perl-proc-processtable
+pkgver=0.45
+pkgrel=2
+pkgdesc="Provides a consistent interface to process table information."
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/dist/Proc-ProcessTable/"
+license=('PerlArtistic')
+depends=('perl')
+provides=('perl-proc-killall=1.0.0' 'perl-proc-killfam=1.0.0' 'perl-proc-processtable-process=0.20.0')
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/D/DU/DURIST/Proc-ProcessTable-$pkgver.tar.gz")
+md5sums=('4481495d639c314f57e6d9d25f23c88e')
+
+build() {
+ cd $srcdir/Proc-ProcessTable-$pkgver
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd $srcdir/Proc-ProcessTable-$pkgver
+
+ make install DESTDIR="${pkgdir}"
+ find ${pkgdir} -name perllocal.pod -delete
+ find ${pkgdir} -name .packlist -delete
+}
+