summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/plextor-convertX-driver/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/core/plextor-convertX-driver/PKGBUILD')
-rwxr-xr-xabs/not_built/core/plextor-convertX-driver/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/abs/not_built/core/plextor-convertX-driver/PKGBUILD b/abs/not_built/core/plextor-convertX-driver/PKGBUILD
new file mode 100755
index 0000000..8b203f6
--- /dev/null
+++ b/abs/not_built/core/plextor-convertX-driver/PKGBUILD
@@ -0,0 +1,36 @@
+
+
+pkgname=plextor-convertX-driver
+pkgver=0.9.8
+pkgrel=7
+_kernver=2.6.28-LinHES
+pkgdesc="Drivers for Plextor tuners"
+arch=(i686 x86_64)
+url="http://nikosapi.org/software/WIS_Go7007"
+install="convertX.install"
+source=("http://go7007.imploder.org/wp-content/uploads/2009/02/wis-go7007-linux-098-4tar.bz2" 'wis-go7007-2.6.26-nopage.diff' 'wis-go7007-linux-0.9.8-2-2.6.27.patch')
+depends=('udev>=070' 'fxload')
+makedepends=('gcc')
+options=(!strip)
+
+build() {
+
+ # SET UP
+ cd $startdir/src/wis-go7007-linux-0.9.8-4 || return 1
+# patch -Np1 -i ../wis-go7007-2.6.26-nopage.diff || return 1
+# patch -Np1 -i ../wis-go7007-linux-0.9.8-2-2.6.27.patch || return 1
+ # build
+ make clean || return 1
+ make || return 1
+ mkdir -p $startdir/pkg/usr/src/linux-$_kernver/include/linux
+ mkdir -p $startdir/pkg/etc/udev/rules.d
+ mkdir -p $startdir/pkg/usr/bin
+ mkdir -p $startdir/pkg/usr/sbin
+ # install
+ make DESTDIR=$startdir/pkg install || return 1
+ install -m755 apps/gorecord $startdir/pkg/usr/bin/gorecord
+ install -m755 apps/modet $startdir/pkg/usr/bin/modet
+}
+md5sums=('b4299b6e2fcbaf461bc8afe36654f314'
+ 'e4c7bc33d6e69eafc10bd107cf648828'
+ '3b89d8746adf70102eeeb47d03627ece')