summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/procps/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/core/procps/PKGBUILD')
-rw-r--r--abs/not_built/core/procps/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/not_built/core/procps/PKGBUILD b/abs/not_built/core/procps/PKGBUILD
new file mode 100644
index 0000000..84c3a19
--- /dev/null
+++ b/abs/not_built/core/procps/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 39239 2009-05-14 06:04:46Z eric $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
+
+pkgname=procps
+pkgver=3.2.8
+pkgrel=1
+pkgdesc="Utilities for monitoring your system and processes on your system"
+arch=('i686' 'x86_64')
+url="http://procps.sourceforge.net/"
+license=('GPL' 'LGPL')
+groups=('base')
+depends=('ncurses')
+backup=('etc/sysctl.conf')
+source=(http://procps.sourceforge.net/procps-${pkgver}.tar.gz sysctl.conf)
+md5sums=('9532714b6846013ca9898984ba4cd7e0' '9be3a131a7068aae11418e6dd99e2221')
+sha1sums=('a0c86790569dec26b5d9037e8868ca907acc9829' '9b9a314010d042b5aa487893c06f361531525e6a')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ sed -i "s:\$(lib64):lib:" Makefile || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" ldconfig=/bin/true install || return 1
+ install -D -m644 "${srcdir}/sysctl.conf" "${pkgdir}/etc/sysctl.conf" || return 1
+ install -d "${pkgdir}/usr/include/proc" || return 1
+ install -m644 proc/*.h "${pkgdir}/usr/include/proc" || return 1
+}