summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/python_modules/python-pyserial/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/core/python_modules/python-pyserial/PKGBUILD')
-rw-r--r--abs/not_built/core/python_modules/python-pyserial/PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/abs/not_built/core/python_modules/python-pyserial/PKGBUILD b/abs/not_built/core/python_modules/python-pyserial/PKGBUILD
new file mode 100644
index 0000000..43c5b87
--- /dev/null
+++ b/abs/not_built/core/python_modules/python-pyserial/PKGBUILD
@@ -0,0 +1,21 @@
+# $Id: PKGBUILD 29428 2010-10-14 09:13:52Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Douglas Soares de Andrade <dsandrade@gmail.com>
+# Contributor: Douglas Soares de Andrade <dsandrade@gmail.com>
+
+pkgname=python-pyserial
+pkgver=2.5
+pkgrel=3
+pkgdesc="Multiplatform Serial Port Module for Python"
+arch=('any')
+url="http://pyserial.sf.net"
+license=('custom:PYTHON')
+depends=('python2')
+source=(http://downloads.sourceforge.net/sourceforge/pyserial/pyserial-$pkgver.tar.gz)
+md5sums=('34340820710239bea2ceca7f43ef8cab')
+
+build() {
+ cd $srcdir/pyserial-$pkgver
+ python2 setup.py install --root=$pkgdir
+ install -D -m644 LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE.txt
+}