summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/python_modules/python2-distribute/distribute-0.6.14_python2_and_3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/core/python_modules/python2-distribute/distribute-0.6.14_python2_and_3.patch')
-rw-r--r--abs/not_built/core/python_modules/python2-distribute/distribute-0.6.14_python2_and_3.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/abs/not_built/core/python_modules/python2-distribute/distribute-0.6.14_python2_and_3.patch b/abs/not_built/core/python_modules/python2-distribute/distribute-0.6.14_python2_and_3.patch
new file mode 100644
index 0000000..dc5da86
--- /dev/null
+++ b/abs/not_built/core/python_modules/python2-distribute/distribute-0.6.14_python2_and_3.patch
@@ -0,0 +1,51 @@
+diff -Naur distribute-0.6.14.ori//distribute.egg-info/entry_points.txt distribute-0.6.14/distribute.egg-info/entry_points.txt
+--- distribute-0.6.14.ori//distribute.egg-info/entry_points.txt 2010-07-14 20:14:10.000000000 -0400
++++ distribute-0.6.14/distribute.egg-info/entry_points.txt 2010-10-21 09:26:43.386667396 -0400
+@@ -31,7 +31,8 @@
+ depends.txt = setuptools.command.egg_info:warn_depends_obsolete
+
+ [console_scripts]
+-easy_install = setuptools.command.easy_install:main
++easy_install-3.1 = setuptools.command.easy_install:main
++easy_install-2.7 = setuptools.command.easy_install:main
+ easy_install-2.6 = setuptools.command.easy_install:main
+
+ [setuptools.file_finders]
+diff -Naur distribute-0.6.14.ori//distribute_setup.py distribute-0.6.14/distribute_setup.py
+--- distribute-0.6.14.ori//distribute_setup.py 2010-07-14 19:53:38.000000000 -0400
++++ distribute-0.6.14/distribute_setup.py 2010-10-21 09:25:18.356667404 -0400
+@@ -299,8 +299,7 @@
+ log.warn('Could not find the install location')
+ return
+ pyver = '%s.%s' % (sys.version_info[0], sys.version_info[1])
+- setuptools_file = 'setuptools-%s-py%s.egg-info' % \
+- (SETUPTOOLS_FAKED_VERSION, pyver)
++ setuptools_file = 'setuptools-%s.egg-info' % SETUPTOOLS_FAKED_VERSION
+ pkg_info = os.path.join(placeholder, setuptools_file)
+ if os.path.exists(pkg_info):
+ log.warn('%s already exists', pkg_info)
+diff -Naur distribute-0.6.14.ori//setup.py distribute-0.6.14/setup.py
+--- distribute-0.6.14.ori//setup.py 2010-07-14 19:53:38.000000000 -0400
++++ distribute-0.6.14/setup.py 2010-10-21 09:32:44.850000736 -0400
+@@ -96,6 +96,8 @@
+ f.close()
+
+
++console_scripts = ["easy_install-%s = setuptools.command.easy_install:main" % sys.version[:3]]
++
+ # if we are installing Distribute using "python setup.py install"
+ # we need to get setuptools out of the way
+ def _easy_install_marker():
+@@ -182,11 +184,7 @@
+ "dependency_links.txt = setuptools.command.egg_info:overwrite_arg",
+ ],
+
+- "console_scripts": [
+- "easy_install = setuptools.command.easy_install:main",
+- "easy_install-%s = setuptools.command.easy_install:main"
+- % sys.version[:3]
+- ],
++ "console_scripts": console_scripts,
+
+ "setuptools.file_finders":
+ ["svn_cvs = setuptools.command.sdist:_default_revctrl"],