summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/bash-completion/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/extra/bash-completion/PKGBUILD')
-rw-r--r--abs/not_built/extra/bash-completion/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/not_built/extra/bash-completion/PKGBUILD b/abs/not_built/extra/bash-completion/PKGBUILD
new file mode 100644
index 0000000..a20fa08
--- /dev/null
+++ b/abs/not_built/extra/bash-completion/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 95183 2010-10-16 21:57:23Z eric $
+# Maintainer: Aaron Griffin <aaron@archlinux.org>
+
+pkgname=bash-completion
+pkgver=1.2
+pkgrel=2
+pkgdesc="Programmable completion for the bash shell"
+arch=('any')
+url="http://bash-completion.alioth.debian.org/"
+license=('GPL')
+depends=('bash')
+source=(http://bash-completion.alioth.debian.org/files/$pkgname-$pkgver.tar.bz2)
+md5sums=('88c022a98a02a02293716f840eadd884')
+sha1sums=('47e6fb919ae227e74172870379b0fe999a2ae70d')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # fixes for archlinux
+ sed -i 's#/sbin" lsmod#/bin" lsmod#' bash_completion
+
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+
+# Doesn't work on Arch Linux and cause problems (FS#20112)
+ rm "$pkgdir/etc/bash_completion.d/service"
+}
+