summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/ccache/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/extra/ccache/PKGBUILD')
-rw-r--r--abs/not_built/extra/ccache/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/not_built/extra/ccache/PKGBUILD b/abs/not_built/extra/ccache/PKGBUILD
new file mode 100644
index 0000000..95c0788
--- /dev/null
+++ b/abs/not_built/extra/ccache/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 98352 2010-11-08 08:19:09Z giovanni $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=ccache
+pkgver=3.1.1
+pkgrel=1
+pkgdesc="A compiler cache"
+url="http://ccache.samba.org/"
+source=(http://samba.org/ftp/${pkgname}/$pkgname-$pkgver.tar.bz2)
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('zlib')
+md5sums=('7dbd668c79d78c0b32c13214b2b35b70')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make || return 1
+ install -Dm 755 ccache ${pkgdir}/usr/bin/ccache
+ install -Dm 644 ccache.1 ${pkgdir}/usr/share/man/man1/ccache.1
+
+ mkdir -p ${pkgdir}/usr/lib/ccache/bin
+ ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/cc
+ ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/gcc
+ ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/g++
+ ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/cpp
+ ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/c++
+ ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/${CHOST}-cc
+ ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/${CHOST}-gcc
+ ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/${CHOST}-g++
+ ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/${CHOST}-cpp
+ ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/${CHOST}-c++
+}