summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/community/libdnet/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/extra/community/libdnet/PKGBUILD')
-rw-r--r--abs/not_built/extra/community/libdnet/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/not_built/extra/community/libdnet/PKGBUILD b/abs/not_built/extra/community/libdnet/PKGBUILD
new file mode 100644
index 0000000..70cf6e4
--- /dev/null
+++ b/abs/not_built/extra/community/libdnet/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 27071 2010-09-17 12:26:08Z schuay $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: James Fryman <jfryman@gmail.com>
+
+pkgname=libdnet
+pkgver=1.12
+pkgrel=5
+pkgdesc="A simplified, portable interface to several low-level networking routines"
+arch=(i686 x86_64)
+makedepends=(python2)
+optdepends=(python2)
+install=(libdnet.install)
+license=("BSD")
+url="http://code.google.com/p/libdnet/"
+options=('!libtool')
+source=(http://libdnet.googlecode.com/files/libdnet-$pkgver.tgz)
+md5sums=('9253ef6de1b5e28e9c9a62b882e44cc9')
+
+build() {
+ mkdir -p $pkgdir/usr/bin
+
+ [ $CARCH == "x86_64" ] && export CFLAGS=-fPIC
+
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make && make DESTDIR=$pkgdir install
+
+ cd python && \
+ python2 setup.py install --root=$pkgdir
+
+ install -D -m0644 ../LICENSE $pkgdir/usr/share/licenses/libdnet/license
+ mv $pkgdir/usr/man $startdir/pkg/usr/share/
+}