summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/community/mythpywii/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/extra/community/mythpywii/PKGBUILD')
-rw-r--r--abs/not_built/extra/community/mythpywii/PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/abs/not_built/extra/community/mythpywii/PKGBUILD b/abs/not_built/extra/community/mythpywii/PKGBUILD
new file mode 100644
index 0000000..509db19
--- /dev/null
+++ b/abs/not_built/extra/community/mythpywii/PKGBUILD
@@ -0,0 +1,37 @@
+# $Id: PKGBUILD 5936 2008-07-21 20:24:16Z thomas $
+# Maintainer: Cecil Watson<knoppmyth@gmail.com>
+
+pkgname=mythpywii
+pkgver=17
+pkgrel=9
+pkgdesc="Control MythTV using Wiimote."
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://www.benjiegillam.com/"
+depends=('bluez' 'python-pybluez' 'cwiid-git')
+install=mythpywii.install
+source=(http://www.benjiegillam.com/code/myth_py_wii.py \
+ wiimote.rules mythpywii.install CONTROLS)
+
+. /usr/MythVantage/bin/install_functions.sh
+home_check
+
+build() {
+
+ /bin/true
+
+}
+
+package() {
+ install -D -m755 ${srcdir}/myth_py_wii.py ${startdir}/pkg/usr/bin/myth_py_wii.py || return 1
+ install -D -m644 ${srcdir}/wiimote.rules ${startdir}/pkg/etc/udev/rules.d/z90-wiimote.rules || return 1
+ install -d -o mythtv -g mythtv ${startdir}/pkg/$MYTHHOME/.cwiid/wminput || return 1
+ install -D -m755 -o mythtv -g mythtv /etc/cwiid/wminput/{acc_led,buttons,gamepad,neverball,nunchuk_stick2btn,acc_ptr,ir_ptr,nunchuk_acc_ptr} ${startdir}/pkg/$MYTHHOME/.cwiid/wminput || return 1
+ install -D -m644 ${srcdir}/CONTROLS ${startdir}/pkg/usr/share/docs/mythpywii/CONTROLS || return 1
+ cd ${startdir}/pkg$MYTHHOME/.cwiid/wminput
+ ln -s acc_led default
+}
+md5sums=('52b756c403349640c3e66f485b6c0a54'
+ '0d817a971d414b9320587a4cf289386b'
+ '18a4c2936a731191e2db92211b254b66'
+ '0872cbdb3def3dd9aa2b97b191ad76d8')