summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/community/unrar/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/extra/community/unrar/PKGBUILD')
-rw-r--r--abs/not_built/extra/community/unrar/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/not_built/extra/community/unrar/PKGBUILD b/abs/not_built/extra/community/unrar/PKGBUILD
new file mode 100644
index 0000000..20d5213
--- /dev/null
+++ b/abs/not_built/extra/community/unrar/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 72474 2010-03-16 19:39:31Z giovanni $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: dorphell <dorphell@gmx.net>
+
+pkgname=unrar
+pkgver=3.9.10
+pkgrel=1
+pkgdesc="The RAR uncompression program"
+arch=('i686' 'x86_64')
+url="http://www.rarlab.com/rar_add.htm"
+license=('custom')
+depends=('gcc-libs')
+source=(http://www.rarlab.com/rar/unrarsrc-${pkgver}.tar.gz)
+md5sums=('3c130ae52ff9fece50af988c343e396d')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ make -f makefile.unix
+ install -Dm755 unrar ${pkgdir}/usr/bin/unrar || return 1
+ # install license
+ install -Dm644 license.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" || return 1
+}