summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/cvs/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/extra/cvs/PKGBUILD')
-rw-r--r--abs/not_built/extra/cvs/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/not_built/extra/cvs/PKGBUILD b/abs/not_built/extra/cvs/PKGBUILD
new file mode 100644
index 0000000..26b95db
--- /dev/null
+++ b/abs/not_built/extra/cvs/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 75326 2010-04-01 10:25:20Z allan $
+# Contributor: dorphell <dorphell@archlinux.org>
+
+pkgname=cvs
+pkgver=1.11.23
+pkgrel=5
+pkgdesc="Concurrent Versions System - a source control system"
+arch=(i686 x86_64)
+url="http://cvs.nongnu.org"
+license=('GPL')
+depends=('heimdal>=1.3.1')
+optdepends=('openssh: for using cvs over ssh' 'inetutils: for using cvs over rsh')
+install=cvs.install
+source=(ftp://ftp.gnu.org/non-gnu/cvs/source/stable/$pkgver/$pkgname-$pkgver.tar.bz2
+ cvs-1.11.23-getline64.patch)
+sha256sums=('400f51b59d85116e79b844f2d5dbbad4759442a789b401a94aa5052c3d7a4aa9'
+ '9126d7992ace943980ad8a10d5a09aeb6f1eeeb9b921fc796fe31de7b1c220cf')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ unset EDITOR VISUAL
+
+ patch -Np1 -i $srcdir/cvs-1.11.23-getline64.patch || return 1
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=$pkgdir install
+ rm ${pkgdir}/usr/share/info/dir
+}