summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/fakeroot/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/extra/fakeroot/PKGBUILD')
-rw-r--r--abs/not_built/extra/fakeroot/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/not_built/extra/fakeroot/PKGBUILD b/abs/not_built/extra/fakeroot/PKGBUILD
new file mode 100644
index 0000000..688c3d3
--- /dev/null
+++ b/abs/not_built/extra/fakeroot/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 29508 2009-03-09 17:06:43Z andyrtr $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Jochem Kossen <j.kossen@home.nl>
+
+pkgname=fakeroot
+pkgver=1.14.4
+pkgrel=1
+pkgdesc="Gives a fake root environment, useful for building packages as a non-privileged user"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://packages.debian.org/fakeroot"
+groups=('base-devel')
+install=fakeroot.install
+depends=('glibc' 'filesystem' 'grep' 'sed')
+options=('!libtool')
+source=(http://ftp.debian.org/debian/pool/main/f/$pkgname/${pkgname}_${pkgver}.orig.tar.bz2)
+
+build() {
+ cd ${srcdir}/$pkgname-$pkgver
+ ./configure --prefix=/usr --libdir=/usr/lib/libfakeroot \
+ --disable-static --with-ipc=sysv
+ # --with-ipc=tcp is currently broken and no option on smp systems
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+ # install README for sysv/tcp usage
+ install -Dm644 $srcdir/$pkgname-$pkgver/README $pkgdir/usr/share/doc/$pkgname/README
+}
+md5sums=('bea628be77838aaa7323a2f7601c2d7e')