summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/gnome-menus/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/extra/gnome-menus/PKGBUILD')
-rw-r--r--abs/not_built/extra/gnome-menus/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/not_built/extra/gnome-menus/PKGBUILD b/abs/not_built/extra/gnome-menus/PKGBUILD
new file mode 100644
index 0000000..60b4632
--- /dev/null
+++ b/abs/not_built/extra/gnome-menus/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 99752 2010-11-17 11:52:09Z ibiru $
+# Maintainer: Jan de Groot <jan@archlinux.org>
+
+pkgname=gnome-menus
+pkgver=2.30.5
+pkgrel=1
+pkgdesc="GNOME menu specifications"
+arch=('i686' 'x86_64')
+depends=('pygtk>=2.22.0')
+makedepends=('pkg-config' 'intltool' 'gobject-introspection')
+options=('!libtool' '!makeflags')
+license=('GPL' 'LGPL')
+url="http://www.gnome.org"
+source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname}/2.30/${pkgname}-${pkgver}.tar.bz2
+ menus.patch)
+sha256sums=('6dcc565006d6e8c2025ae83ab1f82edf6bd04d61c804c0dc9bf5ea50629c4caa'
+ 'df2779777906b038fa911dc745534564ede9524a64ab368e2f6f8e38d54e7acc')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np0 -i "${srcdir}/menus.patch"
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static
+ make || return 1
+}
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ sed -i "s|#!/usr/bin/env python|#!/usr/bin/env python2|" \
+ $pkgdir/usr/lib/python2.7/site-packages/GMenuSimpleEditor/config.py
+}