summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/libgda/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/extra/libgda/PKGBUILD')
-rw-r--r--abs/not_built/extra/libgda/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/abs/not_built/extra/libgda/PKGBUILD b/abs/not_built/extra/libgda/PKGBUILD
new file mode 100644
index 0000000..72c9404
--- /dev/null
+++ b/abs/not_built/extra/libgda/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 99473 2010-11-14 19:52:55Z ibiru $
+# Maintainer: tobias <tobias@archlinux.org>
+# Contributor: Tobias Kieslich <tobias@justdreams.de>
+
+pkgname=libgda
+pkgver=4.2.1
+pkgrel=2
+pkgdesc="data abstraction layer; with mysql, pgsql, xml, sqlite providers"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('glib2>=2.26.0' 'libxslt' 'db>=5.1.19' 'ncurses>=5.7' 'libsoup>=2.32.0' 'libmysqlclient>=5.1.59' 'postgresql-libs>=9.0.1')
+makedepends=('intltool')
+options=('!libtool')
+url="http://www.gnome-db.org"
+source=(http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/4.2/${pkgname}-${pkgver}.tar.bz2)
+sha256sums=('d485d24fb19bd95faad196c8ed22b2cb8f9e9275d907f880a3f8f079f6bf40f7')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ sed -i -e 's/python/python2/' libgda-report/RML/trml*/trml*.py
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --with-bdb=/usr --with-bdb-libdir-name=lib \
+ --disable-static
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}