summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/liboil/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/extra/liboil/PKGBUILD')
-rw-r--r--abs/not_built/extra/liboil/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/not_built/extra/liboil/PKGBUILD b/abs/not_built/extra/liboil/PKGBUILD
new file mode 100644
index 0000000..e206abb
--- /dev/null
+++ b/abs/not_built/extra/liboil/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 72222 2010-03-13 20:12:59Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=liboil
+pkgver=0.3.17
+pkgrel=1
+pkgdesc="Library of simple functions that are optimized for various CPUs."
+arch=('i686' 'x86_64')
+license=('custom')
+url="http://liboil.freedesktop.org/"
+depends=('glibc')
+makedepends=('glib2' 'pkgconfig' 'docbook-xsl')
+options=('!libtool' '!makeflags')
+source=(${url}/download/${pkgname}-${pkgver}.tar.gz)
+md5sums=('47dc734f82faeb2964d97771cfd2e701')
+
+build() {
+ unset CFLAGS
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+ install -m755 -d "${pkgdir}/usr/share/licenses/liboil"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/liboil/" || return 1
+}