summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/libupnp/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/extra/libupnp/PKGBUILD')
-rw-r--r--abs/not_built/extra/libupnp/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/not_built/extra/libupnp/PKGBUILD b/abs/not_built/extra/libupnp/PKGBUILD
new file mode 100644
index 0000000..39cfef7
--- /dev/null
+++ b/abs/not_built/extra/libupnp/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id$
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: kastor <kastor@fobos.org.ar>
+
+pkgname=libupnp
+pkgver=1.6.13
+pkgrel=1
+pkgdesc="Portable Open Source UPnP Development Kit"
+arch=('i686' 'x86_64')
+url="http://pupnp.sourceforge.net/"
+license=('BSD')
+depends=('glibc')
+makedepends=('pkgconfig')
+options=('!libtool')
+source=("http://downloads.sourceforge.net/sourceforge/pupnp/${pkgname}-${pkgver}.tar.bz2")
+md5sums=('71476b1781ad179bfc9bead640be5f54')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR=${pkgdir} install
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/custom/${pkgname}/LICENSE
+}
+