summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/libxklavier/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/extra/libxklavier/PKGBUILD')
-rw-r--r--abs/not_built/extra/libxklavier/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/not_built/extra/libxklavier/PKGBUILD b/abs/not_built/extra/libxklavier/PKGBUILD
new file mode 100644
index 0000000..06e6444
--- /dev/null
+++ b/abs/not_built/extra/libxklavier/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 68544 2010-02-13 09:51:41Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Arjan Timmerman <arjan@archlinux.org>
+
+pkgname=libxklavier
+pkgver=5.0
+pkgrel=1
+pkgdesc="High-level API for X Keyboard Extension"
+arch=('i686' 'x86_64')
+license=('LGPL')
+depends=('libxkbfile>=1.0.5' 'libxml2>=2.7.6' 'glib2>=2.22.3' 'xkeyboard-config>=1.6' 'libxi>=1.2.1' 'iso-codes>=3.10.1')
+makedepends=('pkgconfig')
+options=('!libtool' '!emptydirs')
+url="http://gswitchit.sourceforge.net"
+source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.bz2)
+sha256sums=('dfd94b17a752b2839281764f0a16af2b338024c8867c10fba7015f276dec4db0')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr \
+ --with-xkb-base=/usr/share/X11/xkb --disable-static || return 1
+ make || return 1
+}
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install || return 1
+}