summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/pptpclient/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/extra/pptpclient/PKGBUILD')
-rw-r--r--abs/not_built/extra/pptpclient/PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/abs/not_built/extra/pptpclient/PKGBUILD b/abs/not_built/extra/pptpclient/PKGBUILD
new file mode 100644
index 0000000..f94a7d2
--- /dev/null
+++ b/abs/not_built/extra/pptpclient/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Daniel Isenmann <daniel @ archlinux.org>
+# Contributor: Mark Nikkel <mnikkel@gmail.com>
+pkgname=pptpclient
+pkgver=1.7.2
+pkgrel=2
+pkgdesc="Client for the proprietary Microsoft Point-to-Point Tunneling Protocol, PPTP."
+url="http://pptpclient.sourceforge.net/"
+license=('GPL')
+depends=(glibc ppp iproute2)
+backup=(etc/ppp/{options.pptp})
+source=(http://downloads.sourceforge.net/sourceforge/pptpclient/pptp-$pkgver.tar.gz)
+md5sums=('4c3d19286a37459a632c7128c92a9857')
+arch=('i686' 'x86_64')
+
+build() {
+ cd $srcdir/pptp-$pkgver
+ sed -i '/CFLAGS/d' Makefile
+ sed -i 's|\/bin\/ip|\/usr\/sbin\/ip|g' routing.c
+ make || return 1
+ make DESTDIR=$pkgdir install
+}