summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/qscintilla/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/extra/qscintilla/PKGBUILD')
-rw-r--r--abs/not_built/extra/qscintilla/PKGBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/abs/not_built/extra/qscintilla/PKGBUILD b/abs/not_built/extra/qscintilla/PKGBUILD
new file mode 100644
index 0000000..b0f83be
--- /dev/null
+++ b/abs/not_built/extra/qscintilla/PKGBUILD
@@ -0,0 +1,59 @@
+# $Id$
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Douglas Soares de Andrade <dsa@aur.archlinux.org>
+
+pkgbase=qscintilla
+pkgname=('qscintilla' 'python2-qscintilla')
+pkgver=2.5.1
+pkgrel=3
+license=('GPL')
+arch=('i686' 'x86_64')
+url="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
+makedepends=('python2-pyqt')
+source=("http://riverbankcomputing.com/static/Downloads/QScintilla2/QScintilla-gpl-${pkgver}.tar.gz"
+ 'configure.py-objdir-support.diff')
+md5sums=('dd7edef5ff674d307057a3c12dbd8fce'
+ '8cf9c06252e2f11ab00e62848e322fd3')
+
+
+build() {
+ cd "${srcdir}/QScintilla-gpl-${pkgver}"
+ patch -Np1 -i "${srcdir}/configure.py-objdir-support.diff"
+
+ cd Qt4
+ qmake qscintilla.pro
+ make
+
+ cd ../designer-Qt4
+ qmake designer.pro INCLUDEPATH+=../Qt4 QMAKE_LIBDIR+=../Qt4
+ make
+
+ cd ../
+ cp -rf Python Python2
+ cd Python
+ python configure.py -n ../Qt4/ -o ../Qt4 -c -p 4
+ make
+
+ cd ../Python2
+ python2 configure.py -n ../Qt4/ -o ../Qt4 -c -p 4
+ make
+}
+
+package_qscintilla() {
+ pkgdesc="A port to Qt4 of Neil Hodgson's Scintilla C++ editor class"
+ depends=('qt')
+
+ cd "${srcdir}/QScintilla-gpl-${pkgver}/Qt4"
+ make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
+
+ cd "${srcdir}/QScintilla-gpl-${pkgver}/designer-Qt4"
+ make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
+}
+
+package_python2-qscintilla() {
+ pkgdesc="Python 2 bindings for QScintilla2"
+ depends=('pyqt' 'qscintilla')
+
+ cd "${srcdir}/QScintilla-gpl-${pkgver}/Python2"
+ make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
+}